Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

I can't complete the download/installation of the game

STAR WARS: The Old Republic > English > Customer Service
I can't complete the download/installation of the game
First BioWare Post First BioWare Post

jarowan's Avatar


jarowan
01.01.2012 , 06:38 PM | #291
Customer Service called me in response to my tickets to apologize and say they'd fixed the problem with the most recent patch. Indeed, I was able to download the files without any corrupt bits, so they've apparently scoured the CDN clean of corrupt versions.

Unfortunately, they have NO fixed the memory bug affecting Win7 with more than 4GB of RAM. The installs will still freeze due to the installer corrupting the extracted files, with the result that it will try to redownload the whole thing from scratch. Only managed to get online because I was able to borrow a laptop for the holiday and install it on that and copy the installation folder. This is a ridiculous workaround. So is the main suggestion on the forums to remove memory sticks - with my heatsink position in the case and mobo layout, that's not a minor undertaking. As to reducing available RAM to ~2GB, I've got 16GB in there - what exactly am I supposed to run to tie up 14GB of my system?

Still epic fail. Disappointing, since once getting on I was having fun, but I'm not subscribing if I can expect to have to borrow someone's laptop everytime they issue a 8MB hotfix.

BrightCandle's Avatar


BrightCandle
01.02.2012 , 02:15 AM | #292
Well if its true that would explain the lack of complaints in the forum about download errors yesterday evening to this morning. That is great news.

As to the install error before the whole thing went FUBAR we had two suggested workarounds that seemed to work most of the time.

Short of seeing the contents of that Jar file I don't have any further suggestions. If anyone has an idea on how to get the jar file I'm all ears.

Definition of the problem
----------------------------
Installation of Main Asset 2X fails while unpacking, when you do not have corrupt files.

Known workarounds
------------------------
0) This launcher is very keen on memory stability. You should run memtest for 4 hours to confirm your system is stable. I know you think its stable, many others thought the same thing and then ran the test and failed.

1) Remove your current Java version and install Java 1.6 update 30 x86 Online. Do not install a 64 bit version and do not install Java 7.

2) Run lots of software until you only have about 200MB free, then run the launcher and try it again.
There used to be a repair for launcher problems here, but BioWare Customer Support has banned me from posting the link. My advice is if the launcher does not work is get a refund while you still can.

BrightCandle's Avatar


BrightCandle
01.02.2012 , 06:07 AM | #293
Alas it doesn't look like it is fixed, still reports coming that the download is failing.
There used to be a repair for launcher problems here, but BioWare Customer Support has banned me from posting the link. My advice is if the launcher does not work is get a refund while you still can.

monkeymeetsrobot's Avatar


monkeymeetsrobot
01.02.2012 , 07:53 AM | #294
I was able to get things installed correctly yesterday morning using your method BrightCandle, thank you very much for your help!

My steps
1) Download all the files individually, compare them to the checksum to make sure they matched
2) assets_swtor_en_us_-1to0.z03 did not match the posted checksum in the 10 or so times I downloaded it. Someone had later posted a working checksum, dbabb89f0508ce8e432ce2ce83e2fe0d, which I eventually got, so I decided to try it. I also got 610bb5547a1e17a19362b0e2848bc4b1 a bunch, but I am not sure if this one works.
3) Move the files over and create the folders
4) Restart the computer in safe mode with networking (this seemed to fix the crashes for me, the launcher was locking me up hard when installing)
5) Launch the launcher, let it download the latest patch
6) Wait for it to fail, hit repair, it verified the files I had moved then started installing
7) Once install completed, reboot in non-safe mode.

I am currently able to play without issue.

The one thing others might want to try to mitigate the launcher crashing is installing in safe mode. I am not sure what the conflict is, or if it is specific to my machine, but I was crashing every time I tried to install and this seemed to fix it.

Noddie's Avatar


Noddie
01.02.2012 , 01:16 PM | #295
Oh hai, just back from christmas holiday here.

I see nothing has changed... =/

Quote: Originally Posted by BrightCandle View Post
Alas it doesn't look like it is fixed, still reports coming that the download is failing.
This issue is so sad. I have 12 out of 16 GB of memory currently working as paperweights just because of this game. The worst part of it is, just seeing those 3 modules on my desktop makes me so sad and hurt inside that I rarely feel like playing the game at all! =/

Hope this gets all better soon, cause I liked the game...

Sukrai's Avatar


Sukrai
01.02.2012 , 01:39 PM | #296
English Assets 23 is STILL not downloading even after 3 days. I've reinstalled everything 8 times and even used the backed up files I had to replace corrupted ones. Nothing is working, as it STILL freezes at 0.02 megabytes and refuses to connect. Can someone in Bioware PLEASE get this fixed? This isn't the first time it's happened...

Is it that as soon as it sends a file, they close the connection? That might explain the problem if the lag time then cuts off the connection before the actual information is sent... I know others have had this problem..

Cerimon's Avatar


Cerimon
01.02.2012 , 04:00 PM | #297 This is the last staff post in this thread.  
Greetings All,

If you are continuing to have a problem with downloading assets please follow these steps:

1. Open a command window (type “cmd” in the Start Menu search box and press enter)
2. Enter the command: ping cdn-patch.swtor.com
3. Send us the IP address returned by that command and your launcher log in an email to support@swtor.com

Launcher Logs: In a default installation these files can be found here:
  • 64bit: C:\Program Files (x86)\Electronic Arts\BioWare\Star Wars - The Old Republic\logs
  • 32bit: C:\Program Files\Electronic Arts\BioWare\Star Wars - The Old Republic\logs
Example file name: launcher_20111122.Log

We apologize for any inconvenience caused and Thank You for playing Star Wars™: The Old Republic™

Cerimon | BioWare Customer Service - Forum Support

ZachDenny's Avatar


ZachDenny
01.03.2012 , 12:40 AM | #298
Sooo I suppose the problems still not fixed? Guess I will find out and see after its done downloading in like 6 hours... lol

umadbrahh's Avatar


umadbrahh
01.03.2012 , 05:30 AM | #299
My problem is that the launcher stops responding and closes mid download.

Right now im trying brightcandle's manual option. Will post when I have more to offer.

Miles_Long's Avatar


Miles_Long
01.03.2012 , 05:57 AM | #300
30 paged thread and no legit response from developers?