View Single Post

alexzk's Avatar

11.06.2012 , 04:22 PM | #2
Improoving perfomance under wine.

Okey, If you have SSD - probably u've put everything on it already. If not - move out there "Assets" folder and make a link to it in the game's folder.

Next we can put 2 sensitive files into RAM which boost game twice for me at least.

Let's do virtual disk:

>sudo kate /etc/make_ramcache

Copy/paste this into file:


[ ! -d /ramcache ] && mkdir -p /ramcache
chmod 777 /ramcache
mount -t tmpfs -o size=200m,rw tmpfs /ramcache
touch /ramcache/DiskCacheStatic
chmod 666 /ramcache/DiskCacheStatic
touch /ramcache/DiskCacheStream
chmod 666 /ramcache/DiskCacheStream

Save, exit kate, and:

> sudo chmod +x /etc/make_cache

Let's add it to boot time:

>sudo kate /etc/rc.local

Add line:

save, exit, reboot

After this you should have /ramcache folder with 2 empty game's files.

Next, make a link in your home folder "swtor_settings" pointed to
"/home/USER/PlayOnLinux's virtual drives/SWTOR/drive_c/users/USER/Local Settings/Application Data/SWTOR/swtor/"
You should see here sub-folder "settings" and maybe 2 game's files.

Next, modify "runsw" as follows:

cat /dev/null > /ramcache/DiskCacheStatic
cat /dev/null > /ramcache/DiskCacheStream
ln -s /ramcache/DiskCacheStatic ~/swtor_settings/DiskCacheStatic
ln -s /ramcache/DiskCacheStream ~/swtor_settings/DiskCacheStream

/usr/share/playonlinux/playonlinux --run "Game Itself" %F

This file will put those 2 game's files into ram. It doubles FPS for me. However, game deletes links and creates files on HDD sometimes, not sure why, but check "swtor_settings" before each run and delete those 2 if any.

I give up, those files won. They're deleted for each new location. So full container folder must be moved. It should be /ramcache/swtor/ which has link to folder "settings" with your settings and 2 those files. Hard to writedown all those link-to-link, so please try yourself Boot script creates /ramcache/swtor only now and all other is done by runsw:

[ ! -L ~/pre_swtor/swtor ] && ln -s /ramcache/swtor ~/pre_swtor/swtor
[ ! -L /ramcache/swtor/settings ] && ln -s ~/Games/swtor_settings/settings /ramcache/swtor/settings
/usr/share/playonlinux/playonlinux --run "Game Itself" %F

Looks like there is some 64bit <--->32bit transactions on 64 bit linux system. It's like hundreds of it per second. I opened each link ("Game Itself" file) in text editor (/home/USER/.PlayOnLinux/shortcuts/FILENAME) and added 32 bit mode, so file will look like:
export WINEDEBUG="-all"
export WINEARCH=win32

After that I played 3 WZs before posting this update. I should say I feel a bit better. Now I dont afraid to rotate camera to whatch around while I run.

Also you can add line into original launcher's shortcut so it will always run in desktop:

POL_Wine launcher.exe "$@"
change to:
POL_Wine explorer /desktop=name,1000x600 launcher.exe "$@"

Update 2
The change POL_Wine explorer /desktop=name,1000x600 launcher.exe "$@" may not work when launcher shows news. Fix - close and delete "patcher" folder, sometimes you should do it couple times.

Better performance is when I have "Strict Draw Ordering" set to disabled and Video Memory Size is set lower than I have total (768 out 1024 in my case). Possibly that is because I have 2 monitors.

Update 3

Sound fix for USB dongle:
There is no ignorance - there is knowledge.