Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Can't See Character or World

STAR WARS: The Old Republic > English > Customer Service
Can't See Character or World
First BioWare Post First BioWare Post

Tarshila's Avatar


Tarshila
12.23.2011 , 02:34 AM | #1
I installed Swtor yesterday afternoon 5 hours before I went to work everything went fine I installed it with no problems at all. I setup my account and logged in and watched the opening movie then it tells me to pick a side so I did, then it played the Sith Empire cinematic. After that was done It brought me to the character screen where I could only see the Hud and the class and races along with all the customization options. Thinking it was an easy fix I hit random and started the game once inside the game everything again loaded just fine. Then when everything was done I couldn't see any of the Terrain or my character. I was able to talk to the guy that's right there when you spawn all that also worked just fine. I'm able to move, use Abilities basically I can play the game just I can't see anything that's going on. Other peoples names of there character appear on screen but that's about as far as it goes. I've tried every trick in the book if you can think of it Ive probably tried it already. If anyone thinks this is a graphics card problem or know the real solution please help not being able to play sucks. Also turning up all the settings turns the screen white instead of black if that helps any.

Zylaro's Avatar


Zylaro
12.23.2011 , 02:57 AM | #2
I had something similar in beta and realised my laptop couldn't play the game, my graphics card was not good enough, I too could see all the controls around the edge of the screen, and chat, move my character even though I couldn't see it, etc etc.

I have now got a new computer and all is well. Maybe if you turned all the settings to low, it might help or upgrade your graphics card. Hasve you checked the minimum specs needed to play?

hope you sort it

Scotland's Avatar


Scotland
12.23.2011 , 03:06 AM | #3
ive been playing for a while now and i had this same error yesterday.

ive never had it before tho.

Tarshila's Avatar


Tarshila
12.23.2011 , 03:10 AM | #4
I'm sure its probably the comp and its probably time for a new one anyway guess ill just wait a couple of months before playing and grab a new comp Thx for the help.

Kage_kun's Avatar


Kage_kun
12.24.2011 , 08:40 AM | #5
I'm having the same problem as above but with a slight difference. i can see some things but the menus are empty. there will be a S or a E that shows where words are suppose to be but other then that its all black. i hear sound but find and i can sorta navigate the unknown menus but i can play the game with everything black. Anyone gave a idea what may cause this other then graphics card?

caskew's Avatar


caskew
12.24.2011 , 11:36 AM | #6
I have the same problem, but the one thing i dont understand is that my laptop is more than capable for running this game... maybe i need to download something additional? please someone help, i dying to play this game!

Naugor's Avatar


Naugor
12.24.2011 , 11:51 AM | #7 Click here to go to the next staff post in this thread. Next  
Greetings everyone,

The issue you are experiencing may be related to your graphics card. We would recommend that you make sure that your graphics drivers are up to date. For instructions on how to update your Graphics card please see here.

Also, we would recommend that you check the minimum requirements to run Star Wars: The Old Republic here.

If this doesn't resolve your issue, please get back to us!
Naugor | BioWare Customer Service - Forum Support | Find help for all EA Games at Answer HQ.

bbbblaine's Avatar


bbbblaine
01.02.2013 , 05:30 PM | #8
I am actually having what seems to be the same problem as the original post. However, the difference is, the game was working perfectly fine for me for the past week. Then today, I was disconnected randomly. I rebooted my computer and the game, and now it is having these symptoms. This is clearly not a video card or computer issue, as I am using a clean install of Windows 7 with an Nvidia Geforce GTS 250. Not to mention, as I said previously, the game was working perfectly fine before today.

Beesodd's Avatar


Beesodd
01.02.2013 , 05:44 PM | #9 This is the last staff post in this thread.  
Hi bbbblaine,

Honestly, this does look like it could be a driver or hardware issue. Perhaps there was some corruption of the display drivers, or even an existing fault with the graphics card that just manifested. Things on a computer can and will break mid-flow without any obvious external influence.

That said, first of all we can check if it's an issue with game files. To do so, log into the launcher and click on the cog icon. Then run the repair, and hopefully this will fix the issue.

If not, your best bet would be to ininstall your existing card drivers, and then install a fresh set.

Beesodd | BioWare Customer Service - Forum Support| Find help for all EA Games at Answer HQ.