Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

the Mandalorian Killer

STAR WARS: The Old Republic > English > Classes
the Mandalorian Killer

_Straps_'s Avatar

01.06.2012 , 12:52 AM | #11
I ran into this today. You CAN NOT use your own Jet Charge skill (if you are a Powertech and have it). You must use the one in your Mission Items inventory. Also, it is a pain to use... run around spamming it until it gets you up to the Engineer. After running around for a bit, they started firing on me and then the Mission Item Jet Charge did send me up and it was insta death for the Engineer. What a pain in the rear....

Greyshadow's Avatar

01.07.2012 , 02:00 PM | #12
Unfortunately I still haven't gotten that far, I got stuck after dying.... it's nice of them to put you on the other side of a locked door. So I had to fleet pass to get back

Greyshadow's Avatar

01.07.2012 , 02:51 PM | #13
Oh my god! Again.... this time I made it to the command deck, which is where the medcenter is so I thought I was ok, there IS STILL a locked door to get back around to where the Brig is, WOW did ANYONE think that through?

Megyn's Avatar

01.08.2012 , 07:23 PM | #14
Same exact thing happened to me, and I recently had to use my fleet pass to get out of a bugged zone somewhere else. This is terrible, and obviously poorly planned.

astroboysoup's Avatar

01.16.2012 , 05:43 PM | #15
Feel sorry for you guys that are still stuck. Worked after I figured out how to get past the engineer with the ramjet instant kill.

nitthunt's Avatar

01.16.2012 , 05:58 PM | #16
The quest is not bugged.....completed it first try last week. I read the quest...

puzzlemaniak's Avatar

01.16.2012 , 06:08 PM | #17
^This. Also protip from me - bind q shield and use it every cd, it absorbs ridiculous amounts of dmg, therefore makes some fights on that ship real cake, ie. "duel" with said Jedi or elite pulls.

Noobtookmyname's Avatar

01.17.2012 , 03:27 AM | #18
Quote: Originally Posted by Wolflll View Post
Hey guys, first time posting. I had the same issue with the chief engineer/rocket bug (not the dieing and being stuck part). I put the ramjet upgrade on my hot bar and just ran around the room spamming the button and jumping on things. If you're facing the engineer from the floor, I jumped on the computer banks to your left and noticed the rocket tried to appear on my back for a moment. Then the group agro'ed me and began firing. I jumped back on the computer bank and spammed the rocket while jumping for about 3 seconds until it finally activated.

Long story short, run around the room (nearish the platform but get further while you experiment) spamming the ramjet and you might find the sweet spot to get launched up.

No guarantees but hope it helps!
Thank you soo much, i did exactly what you said and it worked, computer banks on the left guys.

astroboysoup's Avatar

01.19.2012 , 12:16 AM | #19
Quote: Originally Posted by nitthunt View Post
The quest is not bugged.....completed it first try last week. I read the quest...
Yeh, I understood it after I read what you were suppose to do.

Icerina's Avatar

11.10.2012 , 04:18 PM | #20
I just now completed this quest. The doors did lock on me , after respawning to the medical droid. I encountered the locked doors. BUT this is where it got interesting. After being frustrated, I accidently pressed the JETPACK mission item and it ported me THRU the locked doors and onto the ramp, thus killing the engineer and the 2 others.

Hope this helps someone.