Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Program Lock-up on log-in

First BioWare Post First BioWare Post

Master_Almark's Avatar


Master_Almark
06.16.2013 , 07:22 AM | #1
For some unexplained reason, upon logging into the game this morning, I realized that after I've loaded my character into the world, he takes a few steps and TOR locks up. There's not low fps or lag, just grinding halt. Last night, I played for a couple hours with no problem at all, but this morning is a night and day difference. The client freezes, and I have to task manager out of it.

There was no patching or updates to the computer, nothing has changed at all. TOR just broke. And I have no idea where to start.

( Drivers are up to date. )

Master_Almark's Avatar


Master_Almark
06.16.2013 , 08:00 AM | #2
Update: It seems that sometimes, the log-in doesn't make it past the loading screen. It seems to be just that after a certain time has elapsed since logging in, the game freezes.

Master_Almark's Avatar


Master_Almark
06.16.2013 , 12:55 PM | #3
As of now, I've unisntalled/reinstalled. Still broken.

Output's Avatar


Output
06.16.2013 , 04:50 PM | #4
Having same issue. Patch 2.2 seriously broke something.

PointSevenQ's Avatar


PointSevenQ
06.16.2013 , 06:40 PM | #5
I'm having similar issues. Earlier today the game would run, but it was lagging a lot (with the connectivity bars changing frequently). Now it locks up either during login or immediately thereafter.

SomeJagoff's Avatar


SomeJagoff
06.19.2013 , 01:23 PM | #6
Been having this exact same problem since patch 2.1, the cartel market patch.

It's definitely related to switching alts and how frequently.

Example:

Login and play my sniper for 8 hours (pvp/ops/questing/etc.) = all good, no lockup.

Login and switch between 8 alts in half an hour (just standing around on the fleet) = lockup.

It's gotta be some kind of memory leak with patch 2.1. It only started after they had problems with windows xp players not being able to play....except I get the same lockups on my windows 7 computer too.

Maybe something related to the collections interface updating/varying based on toon and switching too quickly causes collections to crash and thus lock up the game? I have various armors/crystals/weapons/etc. unlocked on different toons, not 1 toon with everything, so that would strike me as a possibility, if the internal system is updating constantly by scanning your cargo bay on every toon when you login.

One thing for sure: incredibly annoying.

For any Customer Service person reading this, Patch 2.1 is where it started and patch 2.2 likely spread it to affect more people.

A yellow response here would be greatly appreciated.

P.S. I've submitted about 4 tickets on this so far.
Free Character Transfer & Other Goodies: http://www.swtor.com/r/bgpK6G

Bronholz's Avatar


Bronholz
06.19.2013 , 01:59 PM | #7 This is the last staff post in this thread.  
Greetings,

Thanks for reporting this to us.

The first thing I'd suggest is some general steps to see if this can be improved on the client side:
  • Try running the Repair function from the launcher, this will check for and repair any corruptions in your game files. You can find this by logging into the launcher and clicking the cog icon.
  • With the game closed, navigate to the game folder, and then the swtor sub-folder. In here, find and delete the DiskCacheArena file. Then start the game up again and see if it helps.
  • Make sure you're not running unnecessary programs in the background.
It may be an issue with the game itself, but it's always good to check.

Are the tickets you've made Bug Reports? If not it may well be worth inputting one with as much detail as possible (System information, Details around the crash).

Thanks for your patience.
Bronholz | BioWare Customer Service Forum Support

SomeJagoff's Avatar


SomeJagoff
06.24.2013 , 07:36 AM | #8
Quote: Originally Posted by Bronholz View Post
Greetings,

Thanks for reporting this to us.

The first thing I'd suggest is some general steps to see if this can be improved on the client side:
  • Try running the Repair function from the launcher, this will check for and repair any corruptions in your game files. You can find this by logging into the launcher and clicking the cog icon.
  • With the game closed, navigate to the game folder, and then the swtor sub-folder. In here, find and delete the DiskCacheArena file. Then start the game up again and see if it helps.
  • Make sure you're not running unnecessary programs in the background.
It may be an issue with the game itself, but it's always good to check.

Are the tickets you've made Bug Reports? If not it may well be worth inputting one with as much detail as possible (System information, Details around the crash).

Thanks for your patience.
Thank you for the response Bronholz,

I have run the repair function several times to verify everything was okay (came back fine). I also deleted the diskcachearena file, that actually seemed to make the biggest difference.

I was deleting it before starting the game every time for a week and didn't have too many problems, but then I forgot about it for a week and just avoided toon switching often. Deleting the file did help though.

For the crash, unfortunately there's no information in the event log or anything windows related as the game and windows just freeze requiring a manual reboot with the computer power button. I've detailed the problem in the tickets I submitted.

I'm not sure what happened with 2.1, but that's when the problems started for me. I went from being able to play the game for 8+ hours at a time, cycling through multiple characters without issue, to now being unable to switch through a few characters without a random lockup (but still able to play 1 character only for 8+ hours without issue....so odd) .
Free Character Transfer & Other Goodies: http://www.swtor.com/r/bgpK6G