Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Camera / Mouse Twitching

First BioWare Post First BioWare Post

Boatski's Avatar


Boatski
12.20.2011 , 10:06 PM | #1
Quite often while playing SWTOR my camera will twitch to some random direction. Just about every time I use my right moues button to move the camera, it will randomly twitch and look up or something similar.

All the posts I've seen about this were before the forum wipe so I'm unable to read them.

Is there a fix of any kind?

Ragter's Avatar


Ragter
12.21.2011 , 01:04 AM | #2
i have the same problem.

What kind of mouse are you using?
Ragter - Republic Guild Leader
All Out Assault - Website/ Republic Recruitment Thread/ Sith Recruitment Thread
All Out Assault - Not just a guild...but a gaming community

Boatski's Avatar


Boatski
12.21.2011 , 01:16 AM | #3
Quote: Originally Posted by Ragter View Post
i have the same problem.

What kind of mouse are you using?
Logitech G5.

Hellmet's Avatar


Hellmet
12.21.2011 , 01:27 AM | #4
I have seen the same on my Logitech G300.
It's a trap!

Viscerral's Avatar


Viscerral
12.21.2011 , 02:27 AM | #5
Same issue here, was slightly worried it was my mouse, but you have exactly described my problem. I'm using a Razer Naga.

I'd also like to add that while this is a pretty minor issue it still gets infuriating rather quickly as I've fallen off quite a few bridges/walkways because of this. It's terrible in Huttball as I'm constantly moving the camera around checking for enemies/the ball carrier/people to pass to, and then all the sudden my camera twitches while I'm running and I fall off the walkway.

Wato's Avatar


Wato
12.21.2011 , 05:29 AM | #6
Same here logitech g400. Had same worse issue in beta w/ naga; so much so I had to do everything w/ keyboard. I'm gonna go later today and get a mouse w/ a ball and see if that helps. It seem to me its the pitch, up and down, as often i'm looking down at the top of my toons head and end up doing a 180. It really is quite frustrating.
WE ARE
PENN STATE

BladesWill's Avatar


BladesWill
12.21.2011 , 06:37 AM | #7
I've got the original Logitech G5 Gaming mouse (2 thumb button and weight kit) and I have this issue from time to time. It appears to be a problem with mouse acceleration / sensitivity within the game being unstable. I can click on something, and slightly move mouse and zoom! off it goes for a second then calms back down to normal.

Viscerral's Avatar


Viscerral
12.21.2011 , 01:49 PM | #8
Quote: Originally Posted by BladesWill View Post
It appears to be a problem with mouse acceleration / sensitivity within the game being unstable.
While I agree it does appear that way at first, there are many times when the camera will turn in seemingly random directions, even the opposite from where I'm turning, so for me at least I don't think it's really an issue of the mouse sensitivity momentarily skyrocketing. I also don't have mouse acceleration enabled (not a fan), so I'm a little doubtful that acceleration is the culprit.

AnthoK's Avatar


AnthoK
12.21.2011 , 10:12 PM | #9
I put in a ticket for this. I'm using the Logitch G700 and its crucial that mouse navigation work bug free, especially for raiding. Keyboard turning is way too slow.

If I get a response from Support I will post it back here.

JonnyMark's Avatar


JonnyMark
12.28.2011 , 12:12 PM | #10
I have the same problem, my friend also has the same problem.

I have a Logitech G9X, and this is the only game that causes this for me.
CE Owner, Squadron 367.
http://www.youtube.com/lmleet06
LV 20 Bounty Hunter, Powertech, Shield Tech in Alderaan & Voidstar Warzone.