Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Loading Times

Ewok-Scout's Avatar


Ewok-Scout
02.07.2013 , 03:59 AM | #1
Loading times are ridiculous, takes a good 35-40 seconds or so to get into planets like Alderaan, takes about 8 seconds to load fleet or my ship even, why does it take so long? Should only take 3 seconds tops for any of them.
"No, they won't! What, you think you're some kind of Jedi, waving your hand around like that? I'm a Toydarian! Mind tricks don't work on me; only money." - Watto

Ewok-Scout's Avatar


Ewok-Scout
02.07.2013 , 01:02 PM | #2
Bump/
"No, they won't! What, you think you're some kind of Jedi, waving your hand around like that? I'm a Toydarian! Mind tricks don't work on me; only money." - Watto

itsmymillertime's Avatar


itsmymillertime
02.07.2013 , 01:09 PM | #3
graphics, lots and lots of graphics to load. It also depends how slow your CPU and GPU are and how much RAM you have. Also, how fast your hard drive spins.

Heezdedjim's Avatar


Heezdedjim
02.07.2013 , 01:19 PM | #4
Just another symptom of the underlying disease: they have never, ever done a thorough optimization and cleanup pass on the wretched codebase. The performance of this game on even high end hardware is inexcusable for a "modern" MMO a year out from launch.

venomlash's Avatar


venomlash
02.07.2013 , 01:27 PM | #5
ermahgerd, such a Cadillac problem. I've got a lower-end computer (2009 general use laptop) and it takes me a minute minimum to load into fleet or the Black Hole. Looking at 3 to 5 minutes for big messy planets like Tatooine or Belsavis.
Count your blessings, man. 8 seconds to load fleet, 45 for Tatooine? I should be so lucky!
Quote: Originally Posted by MichelleArcher View Post
Hey there, all! This thread has passed the dreaded 1,000 post limit, and is now in fire. Thanks for the fun, but we feel this discussion as run its course. We will not be restarting this thread.
Jarrant Gartin, Gunnery Commando, Spark of Hope, Begeren Colony

Ewok-Scout's Avatar


Ewok-Scout
02.07.2013 , 02:12 PM | #6
Quote: Originally Posted by itsmymillertime View Post
graphics, lots and lots of graphics to load. It also depends how slow your CPU and GPU are and how much RAM you have. Also, how fast your hard drive spins.
SWTOR is on my RAMDisk. I have 8GB DDR3 RAM and 3GB GFX
"No, they won't! What, you think you're some kind of Jedi, waving your hand around like that? I'm a Toydarian! Mind tricks don't work on me; only money." - Watto

Ewok-Scout's Avatar


Ewok-Scout
02.20.2013 , 03:42 AM | #7
bump.
"No, they won't! What, you think you're some kind of Jedi, waving your hand around like that? I'm a Toydarian! Mind tricks don't work on me; only money." - Watto

NogueiraA's Avatar


NogueiraA
02.20.2013 , 04:05 AM | #8
Quote: Originally Posted by itsmymillertime View Post
graphics, lots and lots of graphics to load. It also depends how slow your CPU and GPU are and how much RAM you have. Also, how fast your hard drive spins.
You're wrong... I'm playing TERA, 5x more beautiful than SWTOR and the loading time it's like 6~7secs inside the major Town with 500+ people in each instance, 10 channels.
Switch instances = 3secs in TERA.

SWTOR engine is bad, it's not CPU or HD problem..
I'll make a video showing the difference between TERA and SWTOR loadings.