Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Stutter increases as I play.

STAR WARS: The Old Republic > English > Customer Service
Stutter increases as I play.

axelthesot's Avatar


axelthesot
01.20.2013 , 08:18 AM | #1
Hey everyone! Came hoping for some small insight into my issue.

My current PC specs:

i5-2500k at OC'ed to 3.3ghz
4gb DDR3
GeForce 550ti 1gb


Used to play SWTOR back when it first launched (with this same computer) and encountered no real frame rate issues outside of a little lag in fleet.

Now when I play, my game will slowly degrade into a stutter fest. It still plays at a smooth 110 fps until the stutter randomly hits and it drops to <10 fps for the duration of the stutter. This starts slowly at first: just a small stutter here and there, then the stutters increase in frequency until it stutters every few seconds and for longer periods.

This process has taken anywhere between 10 minutes to hours of play to get to the point where I have to restart my client because of how bad it is.

Here's the interesting part: Restarting the client completely fixes it. Well, until it decides to start stuttering again.

I've updated every driver I can think of. I've tried running a memory cleaner program that cleans the memory every 5 minutes. I've turned off all processes/services that aren't necessary. I've tweaked every graphic setting possible. I've ran memtests and HDD tests to no avail. I've validated the game files. I've scoured the internet for any possible solution and have yet to find one.

Hopefully someone can help.

Here's my Dxdiag:

Spoiler

OwenBrooks's Avatar


OwenBrooks
01.20.2013 , 08:32 AM | #2
Try the below Nvidia Settings

Go to "manage 3D settings" > "Program Settings" > "Add" (find the swtor.exe from the installed directory) > "Maximum pre-rendered frames = 2" > "Multi-display/mixed-GPU acceleration = Single display performance" > "Power management mode = Prefer maximum performance" > "Triple buffering = ON". The rest of the settings should be left as Default. Make sure you have max-prerendered frames on "2" and Triple buffering = ON

axelthesot's Avatar


axelthesot
01.20.2013 , 08:36 AM | #3
I tried NVIDIA settings like that globally, but the one thread I saw had said Max Pre Rendered Frames to 1.

Trying it with 2 now, and using the profile just for SWTOR.

OwenBrooks's Avatar


OwenBrooks
01.20.2013 , 08:43 AM | #4
Another suggestion is delete the DiskCacheArena file and then run a defrag, this may help if it is hdd based stutter

axelthesot's Avatar


axelthesot
01.20.2013 , 09:16 AM | #5
The NVIDIA settings didn't help, seeing if deleting the Diskcache file works.

OwenBrooks's Avatar


OwenBrooks
01.20.2013 , 09:22 AM | #6
Only oddity I can see in your diag is

Current Mode: 1440 x 900 (32 bit) (75Hz)
Monitor Name: Generic PnP Monitor
Monitor Model: Hanns.G HG191
Monitor Id: HSD0013
Native Mode: 1440 x 900(p) (59.887Hz)

Your Native Mode should say 75Hz but windows wants 60Hz

axelthesot's Avatar


axelthesot
01.20.2013 , 10:52 AM | #7
Switched it all to 60hz.

Unfortunately I still am having the issue.

Thanks everyone for the help so far, hopefully we can figure this out!

axelthesot's Avatar


axelthesot
01.20.2013 , 05:31 PM | #8
Bump.

OwenBrooks's Avatar


OwenBrooks
01.20.2013 , 06:07 PM | #9
Mate
As a thought
Have you checked you have the latest bios in case something is occurring on the motherboard ?

Also update the drivers from the MSI website in case there is MSI specific changes , chipset and sound drivers etc..

OwenBrooks's Avatar


OwenBrooks
01.20.2013 , 06:45 PM | #10
Have you tried running resource monitor to see if it picks up anything at the time of stutter ? it will graph spikes as they occur.