Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

AMD 13.1 Drivers


narcussist's Avatar


narcussist
01.19.2013 , 12:08 PM | #1
Figured I would start a new threw for the new AMD 13.1 drivers for people

I am running Windows 8 64 Pro, Crossfire 6790, 8GB ram,

Previously I was having terrible FPS drops and stuttering while doing anything, runing AMD 12.10 or 12.11b drivers, with average FPS sitting around 15FPS and no animation, basically in a fight it would look like I was just standing there. with settings on very low.

I upgraded to the new 13.1 drivers, and done some testing, on The Black Hole, started with settings turned to very low, and gradually went to very high. I can say I can now play the game on very high setting. So far I have only tested killing mobs, and going to do more tests with FPs and Ops, and will keep most people informed with my tests within this topics.

I would suggest if you run an AMD or ATI card to upgrade to the current drivers if you are having any issues at all.

If others would like to contribute, please do. If anyone needs anymore info, please reply to this thread and I will give my input also.

Giveen's Avatar


Giveen
01.21.2013 , 06:52 AM | #2
I have an AMD 6670, and also was experiencing frame latency. I play on HIGH 1080p, so I am about to login and see hopefully a difference after updating.
(Wow I can't believe this thing kept my sig from SWG)
This my forums, I just let you post here
Giveen - Forum Troll God and Bounty Hunter of COBRA

rtangwai's Avatar


rtangwai
01.21.2013 , 09:11 AM | #3
Tried 13.1 with my setup (HD6950 2GB quad-fire, 8064x1600 Eyefinity 3x1, Core i5-3570K, 16GB RAM) and it still stutters. In fullscreen windowed mode (which disables Crossfire) it is fairly smooth. The gameplay was quite good in Crossfire until the 1.4 patch that broke it.

narcussist's Avatar


narcussist
01.21.2013 , 06:17 PM | #4
an update to my situation.

It was running smooth the first day, and it started to stutter again, in both full and full windowed, I am going to try swapping my cards around and see if that may help but it did work great for a day, will keep you posted on further tests.

narcussist's Avatar


narcussist
01.22.2013 , 08:41 AM | #5
Tried multiple things to get FPS back up and nothing. sitting steady at 15fps even on Very low

Here is my DxDiag

Spoiler

OwenBrooks's Avatar


OwenBrooks
01.22.2013 , 10:33 AM | #6
Quote: Originally Posted by narcussist View Post
Tried multiple things to get FPS back up and nothing. sitting steady at 15fps even on Very low

Here is my DxDiag

Spoiler
Have a look at the bottom of your DxDiag, you are getting multiple Bex crashes in things like windows installer and as an example one asustech driver not being found and windows live modern photos crash.

Have you tested your memory and investigated what is causing these crashes ?

Being Windows 8 it may be worthwhile to keep an eye on this thread http://www.swtor.com/community/showt...=555798&page=6

narcussist's Avatar


narcussist
01.22.2013 , 11:42 PM | #7
Thanks for your Reply, after searching my event log, the crashes were from an earlier date, when I was trying some different settings, where sometimes setting my compatibility to win xp, sometimes the computer doesnt like it too much, some of the other errors was from the day I reinstalled the OS, and trying to run things before installing updates and drivers, I couldnt figure out what the BEX MsiExec.exe error was caused from, unless it was an update/driver I would run or install, and the system needed a reboot, and restarted before I was able to get back to the pc to postpone it.

Ran a Memory Diagnostics Test, and it reported no errors

OwenBrooks's Avatar


OwenBrooks
01.22.2013 , 11:50 PM | #8
Just found this , it maybe worth a shot, uninstall Hyper V ?

http://answers.microsoft.com/en-us/w...3566eb4?page=2

Edit - Bugger if i find anything else will let you know.

Edit - A BEX event is normally security related, e.g., Buffer Overrun, DEP (Data Execution Prevention)

narcussist's Avatar


narcussist
01.22.2013 , 11:59 PM | #9
not intstalled, thanks for the help so far

narcussist's Avatar


narcussist
01.23.2013 , 11:05 AM | #10
I give up, this is the only game giving me any issues, AC3, Dishonored Various other steam game, dirt3, no issues at all. thanks for the help you have tried to give. I just dont understand, why it worked for one day, and then crapped back out.