Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Second computer browsing gives me high latency & disconnects

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
Second computer browsing gives me high latency & disconnects
First BioWare Post First BioWare Post

Ssaffin's Avatar

12.09.2012 , 01:43 PM | #1
I have 2 computers connected to my Netgear N600 dual band gigabit router. SWTOR runs perfectly when I am the only user on the network. However, when my wife uses the second computer (Mac laptop) to browse (mostly Facebook and Amazon), I get latency spikes that last from 2 to 5 seconds. The in-game latency meter will show 10k+ ms and sometimes the red "x" for a disconnect. The laptop she uses is wireless, however I tried connecting it by cable to the router and I still got the same latency spikes. My Internet is 3 meg dsl, though when I run speed tests it peaks at about 2.6 meg.

I went in the router quality of service settings and set "high" priority to the ports swtor uses and that did not help. When I set them to "highest", the game ran fine but my wife's computer couldn't browse at all. It's as if that gave me 100% of the bandwidth.

I understand this is likely a problem on my end, or perhaps an issue with me having low-bandwidth Internet, but does anyone have any ideas that I could try other than just kicking her off the Internet when I play? Trust me, I've considered it.

Bronholz's Avatar

12.10.2012 , 04:11 AM | #2 This is the last staff post in this thread.  
Greetings Ssaffin,

Thanks for contacting us.

Have you opened the Ports that the game requires on your router?

This could be part of the issue.

Thanks for your patience.
Bronholz | BioWare Customer Service Forum Support