Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

How to Fix Stuttering


Demetriscy's Avatar


Demetriscy
12.11.2012 , 03:21 AM | #11
Quote: Originally Posted by Bredwyn View Post
Worked for me too, thanks a lot!
Glad to hear it!!!

OwenBrooks's Avatar


OwenBrooks
12.11.2012 , 03:36 AM | #12
This will help with stuttering as well

press CTRL + ALT + DELETE to bring up the Task Manager, go to processes, select the game’s respective exe file and set priority above normal or higher. You must do this everytime you play the game.

mtanios's Avatar


mtanios
12.11.2012 , 04:19 AM | #13
Quote: Originally Posted by OwenBrooks View Post
This will help with stuttering as well

press CTRL + ALT + DELETE to bring up the Task Manager, go to processes, select the game’s respective exe file and set priority above normal or higher. You must do this everytime you play the game.
I have tried this, but it keeps saying "access denied". I can set every other program i am running to high priority except for swtor.

Duerre's Avatar


Duerre
01.06.2013 , 05:20 PM | #14
Quote: Originally Posted by Demetriscy View Post
Fix #3: Note: This is the best fix which worked for me, it provided the most smoothest experience. If you have an nVidia GPU, go to "manage 3D settings" > "Program Settings" > "Add" (find the swtor.exe from the installed directory) > "Maximum pre-rendered frames = 1" > "Multi-display/mixed-GPU acceleration = Single display performance" > "Power management mode = Prefer maximum performance" > "Triple buffering = ON". The rest of the settings should be left as Default. Make sure you have max-prerendered frames on "1" and Triple buffering = ON as this is what I suspect is making the game run smooth.

May the Force be with you
Wow. I can't believe this freakin worked! I tip my hat to you Demetriscy. You get 893 gold stars! If this had not worked, I'd have canceled my cartel expansion pre-order in addition to canceling my sub. It was literally THAT bad for me, and I was at my wits end.

Nothing worse than wanting to play a game that the developers don't give a rats tail about optimizing. It's ironic really. Bioware/EA are more concerned about revenue than they are about providing a quality product. Apparently, someone over there missed the class in college where they talk about the link between customer satisfaction and the bottom line. Smart Business 101. And yet the game is still suffering from graphical and immersion breaking bugs that have gone unresolved since launch. It breaks my heart.

Anyway, enough of my little soapbox. Again Deme, thank you for creating this thread and helping people like me.

Demetriscy's Avatar


Demetriscy
01.10.2013 , 05:37 AM | #15
Glad to hear it worked for you

Malkavier's Avatar


Malkavier
01.10.2013 , 06:56 AM | #16
Quote: Originally Posted by mtanios View Post
I have tried this, but it keeps saying "access denied". I can set every other program i am running to high priority except for swtor.
Run Process Explorer as Admin when you want to raise the priority manually, there are also several tools out there that you can use to automate this process every time you start the program.
L50 Annhi Marauder L50 Madness Sorc L17 Gunslinger L23 Pyro Tech L35 Medic OP L17 Marks Sniper L50 Lethality Sniper

"Your fear angers me. My anger feeds my hate. My hate gives me strength."

Uvirith's Avatar


Uvirith
03.16.2013 , 04:06 AM | #17
Quote: Originally Posted by Demetriscy View Post
Fix #3: Note: This is the best fix which worked for me, it provided the most smoothest experience. If you have an nVidia GPU, go to "manage 3D settings" > "Program Settings" > "Add" (find the swtor.exe from the installed directory) > "Maximum pre-rendered frames = 1" > "Multi-display/mixed-GPU acceleration = Single display performance" > "Power management mode = Prefer maximum performance" > "Triple buffering = ON". The rest of the settings should be left as Default. Make sure you have max-prerendered frames on "1" and Triple buffering = ON as this is what I suspect is making the game run smooth.
Oh my god, thank yo SOOOO much. Ive been searching for a solution like that since 1.4 came out.
Youre my hero
Uviryth Hammerhand, Kinetic Combat-Shadow
<Founder>

Mastarbob's Avatar


Mastarbob
12.18.2013 , 09:04 AM | #18
Quote: Originally Posted by Demetriscy View Post
I too have been one of the unfortunate players who have been plagued with frame stuttering ever since patch 1.4 was rolled out. I have scoured the forums in order to find possible fixes and decided to make this thread which combines most 'good' solutions, and will also mention which solution worked best for my system. For the record, I am running an i5 2500k OC'd 4.4GHz, gtx 680 overclocked, 8GB RAM on Win 7 x64. The game is installed on a 7,200rpm HDD and I am not running SWTOR Unleashed (RamDisk).

Fix #1: If you are running with VSYNC on, try downloading a software called Bandicam and in FPS Tab check the "Set FPS limit" box, then input number 58. This is assuming your monitor refresh rate is 60Hz. Run the game and notice whether there are any improvements.

Fix #2: Run the game in Fullscreen (windowed) mode. Personally I don't like this fix and if you are running SLI/Crossfire then it's no good because you would only be running with one GPU.

Fix #3: Note: This is the best fix which worked for me, it provided the most smoothest experience. If you have an nVidia GPU, go to "manage 3D settings" > "Program Settings" > "Add" (find the swtor.exe from the installed directory) > "Maximum pre-rendered frames = 1" > "Multi-display/mixed-GPU acceleration = Single display performance" > "Power management mode = Prefer maximum performance" > "Triple buffering = ON". The rest of the settings should be left as Default. Make sure you have max-prerendered frames on "1" and Triple buffering = ON as this is what I suspect is making the game run smooth.

Fix #4: In the in-game preferences, locate the Nameplate settings and Disable Nameplate Scaling (although this is not really a good fix in my opinion, ruins the experience.

I am running the latest nVidia BETA drivers which can be found on www.nvidia.com

May the Force be with you
Thank you very much man, you saved my life!