Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Anyone else having problems logging in? 1003 error.

STAR WARS: The Old Republic > English > General Discussion
Anyone else having problems logging in? 1003 error.

clickonce's Avatar

12.08.2012 , 11:11 AM | #1
that is all.
Inspiring rage-quits since 2001.

dicemanalthar's Avatar

12.08.2012 , 12:40 PM | #2
the following link is from a thread that i started and got gm assistance logging in. what i did not specify in this thread was that the error i was recieving was 1003, so you may be having partially the same problem i did..

flushing my dns cache combined with a fixlauncher fixed my problem

angrywhiteguy's Avatar

12.08.2012 , 07:33 PM | #3
I started having this problem tonight. Nothing fixes it. I get error 1003 and get kicked back to the server selection screen.

zchsry's Avatar

12.10.2012 , 05:35 AM | #4
pretty much the same thing is happening with me except, for me it started with the game crashing back to the server select screen, I can't log in to Begeren Colony server which all of my characters are on. Any other server works perfectly fine. I really don't want to have to start over with a new Legacy.

yodayoga's Avatar

12.10.2012 , 06:45 AM | #5
I can't even get to the server screen. After I hit enter on the login screen, my screen just cycles forever trying to get to the next screen.

Llunauk's Avatar

12.10.2012 , 07:19 AM | #6
I manage to log in and get into the game (one time with a error code!) and find I'm not connected to the server anymore.. meh!

Lanja's Avatar

12.13.2012 , 08:13 AM | #7
I'm having this problem now as well. I was able to log on and play yesterday afternoon like normal. I went to log on and play last night, was brought to the server selection page and got the Error 1003 message when I went to log onto my server. I thought that perhaps it was due to very high traffic on the server, but I tried it again this morning (when it was back down to light traffic) and still got the Error 1003 message. Nothing has changed on my end since I was successfully logging in and running Section X yesterday afternoon. Anybody know what's going on, and how to fix it? It would seem that this is something on Bioware's end. Is it an intermittent issue and are they getting it sorted out?

Healthrisk's Avatar

12.14.2012 , 12:31 PM | #8
Just got the same error 1003 code. No idea how to fix it. I get to the server selection screen, but can`t get in

JimG's Avatar

12.14.2012 , 12:57 PM | #9
Are you guys running Windows 7? If so, there seems to be a compatibility issue with some versions of Windows 7. I fixed it by going to the launcher app file for the game and changing the file properties under the "compatibility" tab to run as "Windows XP (Service Pack 3)" and that solved it. Before, I could only get into my one main server and I couldn't switch servers or log into any of the other ones. That solution was something I found from other people on the internet after some research and haven't had a single problem with the server log-ins since that. So if you're having these type of problems and have Windows 7, then I'd highly recommend doing that.