Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Windows 8 problems

First BioWare Post First BioWare Post

Kaezil's Avatar


Kaezil
02.25.2013 , 10:45 AM | #71
Quote: Originally Posted by optimuslantern View Post
I've had nothing but issues with swtor crashing for me on Windows 8.
What is happening is that I'll be playing when suddenly everything will just freeze. I still hear music playing but the entire game is dead. It doesn't crash to desktop and I have to close via task manager.
I checked and my graphics card is not overheating, I play everything on high with no lag,
It will just die on me.
In 1.4 I was able to work around this by doing compatibility mode for Windows XP but that no longer works.

The only way I can run without crashing is turning everything down to Very Low, when I can run it at high without lag.
This is something I all but refuse to do, please some help?
My game would freeze, sound would continue though, and I was unable to use task manager to kill the swtor Not Responding process.

Brand new PC. I did update all drivers, but that did not work...so

Here is how I solved it. (I saw that you did the first thing with the compability mode, maybe try windows 7 version instead of compatibility as xp, 2p3)

1) Right-click on the launcher.exe and the actual game .exe's. Set them to run in compatibility mode for windows xp, service pack 3 I think.

2) Open up the setting on your graphics card (mine was Catalyst Control Center) and make sure it is using the Appluication's settings. It was overriding the game with some setting. anti-aliasing or one of those, so I could crash the game on command by using my Trooper's mortar shot.

I did both of those at the same time, so I do not know which was, or maybe it was both, that did the trick. I hope this helps because it was FRUSTRATING and made the game unplayable for Ops.
Meatbag

IngeDanielsen's Avatar


IngeDanielsen
02.25.2013 , 11:26 AM | #72
I am running Windows 8 x64bit without any problems and have no problems with SWTOR.
The tips I can give you is this: Install a full version of Windows 8, avoid upgrading. Do not disable UAC.
Install a CCleaner and clean all your old files. Scan your pc for malware. To do that, use a program called Spybot.

Spybot: www.safer-networking.org/
CCleaner: www.piriform.com/ccleaner

And try to run the game as Adm.

Mr_Meister's Avatar


Mr_Meister
02.25.2013 , 02:17 PM | #73
Quote: Originally Posted by Kaezil View Post
My game would freeze, sound would continue though, and I was unable to use task manager to kill the swtor Not Responding process.

Brand new PC. I did update all drivers, but that did not work...so

Here is how I solved it. (I saw that you did the first thing with the compability mode, maybe try windows 7 version instead of compatibility as xp, 2p3)

1) Right-click on the launcher.exe and the actual game .exe's. Set them to run in compatibility mode for windows xp, service pack 3 I think.

2) Open up the setting on your graphics card (mine was Catalyst Control Center) and make sure it is using the Appluication's settings. It was overriding the game with some setting. anti-aliasing or one of those, so I could crash the game on command by using my Trooper's mortar shot.

I did both of those at the same time, so I do not know which was, or maybe it was both, that did the trick. I hope this helps because it was FRUSTRATING and made the game unplayable for Ops.
This sounds like the types of things I've been doing, but I haven't been doing compatability mode for anything except the launcher. I read somewhere that the launcher was then opening the .exe with the same settings that you give the launcher.

Anyway, I will follow your tips and hope it works! Thanks a lot for your advice.

OwenBrooks's Avatar


OwenBrooks
02.25.2013 , 02:35 PM | #74
worthwhile trying the steps in here

http://www.swtor.com/community/showthread.php?t=602352

Atarimark's Avatar


Atarimark
03.02.2013 , 12:39 PM | #75
Quote: Originally Posted by Sparfir View Post
I got a new computer with Windows 8 and the game keeps crashing. Screen freezes and I can't even close with Task manager. Have to restart computer each time. It's becoming a real pain.
This is the exact same problem my wife is having with Win 8 x64. I've tried all the "suggestions" but still no fix.
Osaris Prakill
Leader of the Alderaan Defense League

Mr_Meister's Avatar


Mr_Meister
04.10.2013 , 06:46 AM | #76
Still having this same problem. Compatability mode doesn't work. It's completely random. Sometimes it doesn't happen for weeks, and then it'll happen every day.

I found a workaround though, kind of. I don't need to restart my computer every time it freezes anyway. I put TOR into the START screen (of windows 8, which you access by pressing the windows key) and then when it freezes, I go to that screen. This is the only screen that will work, because desktop and task manager won't. So, once there, click on TOR, and start it again. Another launcher will open. When you try to log in, it will notice that one is already "running" and so will ask you if you want to close it. Of course, click yes.

Then you have a way of shutting down the program that is not responding without having to restart your computer.

While it's not too much trouble if all you are doing is questing, it's a real pain in places like Warzones or Ops.

Still want a real fix...

OwenBrooks's Avatar


OwenBrooks
04.10.2013 , 06:52 AM | #77
Launcher.exe and swtor.exe (and shortcut) need to be the same compat setting, it can causes issues if they are not set the same.

Setting one and not the other is incorrect info

Nidaarla's Avatar


Nidaarla
04.10.2013 , 06:54 AM | #78
Quote: Originally Posted by optimuslantern View Post
I've had nothing but issues with swtor crashing for me on Windows 8.
What is happening is that I'll be playing when suddenly everything will just freeze. I still hear music playing but the entire game is dead. It doesn't crash to desktop and I have to close via task manager.
I checked and my graphics card is not overheating, I play everything on high with no lag,
It will just die on me.
In 1.4 I was able to work around this by doing compatibility mode for Windows XP but that no longer works.

The only way I can run without crashing is turning everything down to Very Low, when I can run it at high without lag.
This is something I all but refuse to do, please some help?
Runs excellent for me,until this so called expansion, can't get past the launcher patching now, however I don't think it has anything to do with 8 as many folks with diff OS are having the same issue. But yea pre 4/9/13 it ran great on windows 8 pro,no issues at all.

jonathonpatches's Avatar


jonathonpatches
04.12.2013 , 11:42 PM | #79
Unfortunately, sad to report the new gaming Desktop I have just purchased also comes with Windows 8... and have experienced the same issues; game freezes, music still plays, and have to go to taskbar to shut down.

Tried every suggestion I have found in this thread (Windows XP comp compatibility, Windows 7 both launcher and file, update drivers, graphics drivers, run as admin, firewalls and spyware turned off, running in fullscreen windowed, etc.) There have been brief periods of being stable (2-3 hours), but ultimately, all have failed to correct the issue. Flashpoints and PVP is unplayable, as lots of activity on the screen seems to increase the chances of setting it off (only complete about half of the PVP matches).

It is frustrating to see that while this issue has been occurring for a few months, and while I understand not experienced by everyone, that the issue has not been resolved as of yet. Anyone heard anything about addressing this issue? Or are they going to hope that most people stick with Windows 7?

Any other suggestions that haven't been mentioned in this thread?

Mr_Meister's Avatar


Mr_Meister
04.13.2013 , 06:11 AM | #80
Quote: Originally Posted by jonathonpatches View Post
Unfortunately, sad to report the new gaming Desktop I have just purchased also comes with Windows 8... and have experienced the same issues; game freezes, music still plays, and have to go to taskbar to shut down.

Tried every suggestion I have found in this thread (Windows XP comp compatibility, Windows 7 both launcher and file, update drivers, graphics drivers, run as admin, firewalls and spyware turned off, running in fullscreen windowed, etc.) There have been brief periods of being stable (2-3 hours), but ultimately, all have failed to correct the issue. Flashpoints and PVP is unplayable, as lots of activity on the screen seems to increase the chances of setting it off (only complete about half of the PVP matches).

It is frustrating to see that while this issue has been occurring for a few months, and while I understand not experienced by everyone, that the issue has not been resolved as of yet. Anyone heard anything about addressing this issue? Or are they going to hope that most people stick with Windows 7?

Any other suggestions that haven't been mentioned in this thread?
This. This exactly.

I changed my compatibility settings to XP and 7 (this time both .exe and the launcher) and it still froze. Indeed, I logged in, and it froze in 10 minutes. I closed it, started again, and it froze immediately. I've never had an immediate freeze until today. Bad times.

I am really out of ideas. Hoping Bioware will look into it.