Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Launcher won't launch.

First BioWare Post First BioWare Post

Insomnio's Avatar

03.02.2012 , 12:56 AM | #21
Greetings Insomnio,

Is there a launcher.exe process running in your Task Manager?


It was a temporary glitch, I was able to relaunch it after closing it in task manager. Thank god, because downloading the entire game again would have been hell

Hyppyrotta's Avatar

03.02.2012 , 12:57 AM | #22
Quote: Originally Posted by DanielWooly View Post
Yeah, I've double checked and I've downloaded all windows updates, plus if they were already on disc 1, I've done a full install. Who knows, just re-installing now, gonna go through any programs I've got installed that I never use, delete those, just in case they're clashing.
oh, you have to manually dig them up from the disc, the installer to my knowledge wont install .net and c++

DanielWooly's Avatar

03.02.2012 , 01:10 AM | #23
It's not that, I've checked on my list of installed programs, I have both visual c++ and .net framework installed, latest versions. Once this install has finished though I might just try re-install them too, in case there is any undetected errors.
I have just noticed that microsoft .net framework didn't have all features turned on though so I've done that, see if it makes a difference. I'm quite out of my depth here though to be honest. I'm not totally stupid or anything but only have limited knowledge!

Thanks for helping by the way!

Chiazeiel's Avatar

03.02.2012 , 01:46 AM | #24
Hi, I've been having the same problems, tried the suggested fixes, but they dont seem to be working. Got my copy from the Origin store, and have tried installing both from the download link and on Origin. launcher.exe and patches folder created, but no launcher pops up.

DanielWooly's Avatar

03.02.2012 , 02:19 AM | #25
Yeah I still have no solution, I've read tons of other threads, some people seem to be able to delete the patch folder, run fixlauncher and be ok. Not worked for me though, I've tried re installing, re downloading the launcher and everything. Checked my hard disk for errors, checked my .net and c++ are up to date, direct x, quicktime all my hardware drivers. Bit of a nightmare really!!

DanielWooly's Avatar

03.02.2012 , 03:47 AM | #26
If anyone has any more suggestions I would really appreciate it! Nothing seems to work, the swtor launcher just will not launch no matter what!

Hyppyrotta's Avatar

03.02.2012 , 03:53 AM | #27
I think you have tried all the fixes I can think of, but do you have another computer avaible? You could try to install it on that one and then move the installed and patched game to your current one.

and if it does not work on another computer I think you have to download the client online and it seems your retail dvd is just broken

DanielWooly's Avatar

03.02.2012 , 03:59 AM | #28
I don't have another machine available, I'll try downloading and see what happens. Total mystery, I've found a few others with the same issue on the forums, but either they've found a solution and not posted it, or they've give up!

DanielWooly's Avatar

03.02.2012 , 04:11 AM | #29
Deleted it off my computer, but when you download the game client, it's only the 38mb setup folder, then to go any further i obviously need to run the launcher, guessing the launcher downloads the rest of the game. So no joy!

Saulgoodyo's Avatar

03.02.2012 , 06:00 AM | #30
i am having this same exact problem... it has been happening for like 2 weeks now :/ i use to be able to play, but now the fixlauncher goes about 3/4 of the way then disappears and then nothing happens....

then when i try to open the launcher nothing happens and says that its running in my task manager.. i let it sit for about an hr, and nothing... ive tryed everything that i have read to do so not exactly sure where to go from here (even tried downloading it again from the website)