Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

*SOLUTION* NVIDIA BSOD/System Lock-Up/TDR/CTD *SOLUTION*

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
*SOLUTION* NVIDIA BSOD/System Lock-Up/TDR/CTD *SOLUTION*
 

Jesseria's Avatar


Jesseria
02.05.2012 , 02:22 AM | #1
I have been plagued with the BSOD/System Lock-Up/TDR/CTD error since January 4th. Finally, after a full month of playing with system settings, waiting for patches, and re-formatting my machine, I found a solution that actually works!

I am running an Nvidia 560 ti fermi - and I have only tested this on an nvidia system. I have tested this fix on a GTX 250 and a 560 ti fermi (friend of mine had the same problem). There appears to be a problem with the nvidia 3D Vision/Display drivers. Even if you are not using the 3D capabilities of the card, this causes an issue with the way the drivers instruct the card to render graphics.

To fix this problem, perform the following:
  1. Download the latest nVidia Drivers
  2. Launch the installation program, and select a Custom Installation
  3. De-Select any 3D Driver (You don't need them)
  4. Check the "Perform Clean Installation" Check Box
  5. Allow the drivers to install
  6. Right Click the Desktop, and open the nvidia control panel
  7. Under 3D Settings, select Manage 3D Settings
  8. From the Global Settings tab, select Power Management Mode and set it to Prefer Maximum Performance
  9. Open the Program Setting Tab and from the Program drop down menu, select the entry with the SWTOR icon (it should be affiliated with WRC 2 Fia World Rally 2011)
  10. Set Power Management Mode to Prefer Maximum Performance
  11. Set Antialiasing mode to Override any application setting
  12. Set Antilaliasing - Setting to 4x (or higher)
  13. Save all settings

This, effectively, removes the troublesome 3D drivers, ensures that your drivers are providing enough power (if you have a proper PSU installed) to your GPU, and forces nvidia to handle the anti-aliasing, as opposed to the game handling it.

This has resulted in lower graphics card temps, more stable GPU usage, flawless 60 FPS performance everywhere, and most importantly, eliminated any and all System Locks, BSODs, TDRs, and CTDs.

I've play tested this for 5 hours on both of my test machines. Success!!!!

Hopefully this helps the rest of you!

Snottie's Avatar


Snottie
02.05.2012 , 03:46 AM | #2
Thanks! Definitely gonna try, but 5 hours is not enough i think =\

Chronostream's Avatar


Chronostream
02.05.2012 , 08:34 AM | #3
I wonder what the ATI equivalent of these steps would be. I have shifted things over to performance mode and adjusted the AA, but my screen still blacks out and locks up.

Jesseria's Avatar


Jesseria
02.05.2012 , 08:52 AM | #4
Quote: Originally Posted by Chronostream View Post
I wonder what the ATI equivalent of these steps would be. I have shifted things over to performance mode and adjusted the AA, but my screen still blacks out and locks up.
The important part is ensuring that the 3D drivers are not installed. I am not sure if ATI has a Clean Installation function or not - but you need to completely remove your 3D vision drivers - then re-install the drivers without the 3D vision.

Jesseria's Avatar


Jesseria
02.05.2012 , 08:56 AM | #6
Quote: Originally Posted by Snottie View Post
Thanks! Definitely gonna try, but 5 hours is not enough i think =\
Play test was 5 hours on both machines - resulting in a total of 10 hours between the two. Both machines were system locking after only 10 minutes of play - so I am relatively optimistic.

Jesseria's Avatar


Jesseria
02.05.2012 , 08:57 AM | #7
Quote: Originally Posted by JustTed View Post
Feel free to try it out - the suggestion to remove the 3D Vision drivers came from nvidia forum moderators on their site.

Further, this issue is occurring over several different games for several different cards utilizing the 500 series of graphics drivers. Just do a search on nvidia system lock ups in Google, and you'll see that several games are affected by this.

Sorry everyone - can't blame BioWare or EA for this one.

Chronostream's Avatar


Chronostream
02.05.2012 , 09:15 AM | #8
I have a 4890 and it doesn't support HD3D, nor do I even see the option to even access such in the driver installation. Nice try. It was worth looking into.

Jesseria's Avatar


Jesseria
02.05.2012 , 09:19 AM | #9
Quote: Originally Posted by Chronostream View Post
I have a 4890 and it doesn't support HD3D, nor do I even see the option to even access such in the driver installation. Nice try. It was worth looking into.
No problem - I understand that there will be differences in approaching this issue across the NVIDIA/ATI spectrum. But, to be fair, I did clearly state "NVIDIA" in the thread title and in the post itself.

Now, the GTX 250 came out well before 3D was even a fad - however the NVIDIA drivers still install 3D drivers for it (go figure). It could be that ATI isn't giving you the option to not install them.

Be sure there isn't a method of disabling them from the ATI control panel.

Chronostream's Avatar


Chronostream
02.05.2012 , 09:27 AM | #10
That you did. Suppose I'm just desperately trying to find a workaround for whatever patch 1.1.1 did to me.