Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Windows Aero + Fullscreen (windowed) problems

STAR WARS: The Old Republic > English > Customer Service
Windows Aero + Fullscreen (windowed) problems

calibro's Avatar


calibro
01.25.2012 , 11:33 AM | #1
Hello, i'm writing this here because your in-game CS, well, is pretty bad.

Here are my specs:
core i7-920 @3.6 GHz
6 Gb DDR3 RAM
Radeon HD5770 1Gb
Win7 x64
Catalyst 12.1a drivers

I'm running the game @ 1680x1050, 2xAA and 4xAnisotropy forced through Ati CC, all setting on High excl Shadows (off) and VSync (n/a).

And here are problems themselves:

1) The game is currently very choppy when i play in "Fullscreen" mode with Windows Aero on. I had to switch to "Fullscreen (windowed)" and turn off Aero to play comfortably; i don't think it is an actual performance problem, right? So please fix it so i can play without having to turn off Aero.

2) I love "Fullscreen (windowed)" setting in my games, it allows me to alt-tab instantaneously and without any waiting time.
With SWTOR, however, "Fulscreen (windowed)" makes my Windows interface, shall i say, hm, unplayable. Yes, when i alt-tab out of SWTOR using "Fullscreen (windowed)" mode i can barely use Chrome, Skype, other programs and the Windows interface itself (note that Aero is turned off) because all of those are working at like 3-4 fps. I tried to run SWTOR on specific CPU cores and that did not help. Also, Fullscreen (Windowed) does seriously overheat my GPU (running 82C atm), while other games (like Skyrim, WoW, Diablo III @all high) are getting it to 70C max.
Other games like WoW or Diablo III beta run perfectly in Fullscreen (windowed) and do not overheat my GPU.

tl;dr version:
The game is playable with Aero off and Fullscreen (windowed) for me. However, with Fullscreen (windowed) all other programs and Windows interface lag and stutter like Heroes of Might an Magic III on a 8Mb RAM computer.

It's so incrediably annoying and painful!
Please fix this issue so i can comfortably finish a few classes stories and unsub.

Thanks!

renegadeimp's Avatar


renegadeimp
01.25.2012 , 11:40 AM | #2
Have you tried running the game without forcing AA etc on through the driver panel?
Streamline - A guide to speeding up low - mid range Computer systems.
Latency Thread - Latency issue gathering thread..
Have a tech issue you need help with? You can nomally find me on the Customer Support forum.

calibro's Avatar


calibro
01.25.2012 , 12:07 PM | #3
Quote: Originally Posted by renegadeimp View Post
Have you tried running the game without forcing AA etc on through the driver panel?
Just tried it, doesn't help.
In-game AA doesn't work and without AA the game looks terrible.

calibro's Avatar


calibro
01.27.2012 , 03:58 AM | #5
Bump once again.
Tired of stuttering, haven't played the game for 3 days now. Just want to finish the story ;(

renegadeimp's Avatar


renegadeimp
01.27.2012 , 04:16 AM | #6
If its choppy with aero on, then theres something wrong with the configuration of your system. You only usually see that issue on very low end systems.
Streamline - A guide to speeding up low - mid range Computer systems.
Latency Thread - Latency issue gathering thread..
Have a tech issue you need help with? You can nomally find me on the Customer Support forum.

calibro's Avatar


calibro
01.27.2012 , 04:20 AM | #7
Any suggestions on what to check?
I tried different Catalyst drivers (starting from 11.0), didn't work.

renegadeimp's Avatar


renegadeimp
01.27.2012 , 04:23 AM | #8
Tbh, when i had this issue in WoW around 2 years ago, i just wiped my entire system, rebuilt it and pretty much redid it from scratch.

Especially since i hadn't formatted or overhauled my system in months.

My system purred like a kitten after it had a good cleanout and overhaul.
Streamline - A guide to speeding up low - mid range Computer systems.
Latency Thread - Latency issue gathering thread..
Have a tech issue you need help with? You can nomally find me on the Customer Support forum.

lollie's Avatar


lollie
01.27.2012 , 04:29 AM | #9
Instead of using VSync (it might still be "on" after you switched to windowed fullscreen) try using an outside app like Dxtory to cap your fps. Then try switching back to fullscreen and make sure VSync really is off. I capped mine to 80fps using this app.

I found using VSync actually made game run a little choppy.

CAUTION: DO NOT LOAD SWTOR UNLESS YOU HAVE AFTER-MARKET COOLING INSTALLED!!

_______________________

calibro's Avatar


calibro
01.27.2012 , 05:27 AM | #10
Quote: Originally Posted by lollie View Post
Instead of using VSync (it might still be "on" after you switched to windowed fullscreen) try using an outside app like Dxtory to cap your fps. Then try switching back to fullscreen and make sure VSync really is off. I capped mine to 80fps using this app.

I found using VSync actually made game run a little choppy.
VSync is greyed out for me when using Fullscreen (windowed) and is unchecked.