Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

FPS Issues


Handz's Avatar


Handz
12.14.2011 , 11:10 AM | #1
Is anyone else getting fps issues, I basically cannot play with how bad it is, when I did that computer check to see if my computer could run this it said it could, and then I pre order the collectors edition, and wont be able to play it? Sorry to rant just frustrated, what can I do??
IT'S A TRAP!

iRob's Avatar


iRob
12.14.2011 , 11:12 AM | #2
This is a fairly widespread problem it seems and it appears to be on Bioware's end. For now, turn shadows completely off. Not low, off. This should at least make it playable until Bioware address the issue.

Sketchyy's Avatar


Sketchyy
12.14.2011 , 11:13 AM | #3
what he said

Banizor's Avatar


Banizor
12.14.2011 , 11:15 AM | #4
i have the same issue.

turn of shadows, completely

turn of Bloom effects, Completely

turn of spell effects, completely and youll do great
Lieutenant Gulliver - Commando

Tomb of Freedon Nadd

Insert-name-here's Avatar


Insert-name-here
12.14.2011 , 11:16 AM | #5
I cant move or talk to quest givers.

AND IM ON A LOW POPULATED SERVER!
CE VIP Jealous?
I read the title of this thread and the first thing that came to mind was the image of Boba Fett picking up Mako like a baseball bat and beating Jar Jar to death with her.--TheGreatEski

Maeleena's Avatar


Maeleena
12.14.2011 , 11:16 AM | #6
Also might not be a bad idea to update the drivers for your mobo, video card, and sound card if it isn't built in to the mobo.

iRob's Avatar


iRob
12.14.2011 , 11:18 AM | #7
Quote: Originally Posted by Banizor View Post
i have the same issue.

turn of shadows, completely

turn of Bloom effects, Completely

turn of spell effects, completely and youll do great
Spell effects? I have no option for that..

elelr's Avatar


elelr
12.14.2011 , 11:18 AM | #8
Yeah I pretty much can't move in a straight line without it ballsing up. Granted I am playing on a laptop, but my specs far exceed the minimum requirements. I barely managed to get out of the first quest room!

My drivers are all updated to the max and I have the latest DirectX, but still not helping.

Rizdach's Avatar


Rizdach
12.14.2011 , 11:23 AM | #9
If you're using an ATI Radeon graphics card, try this thread:

www.swtor.com/community/showthread.php?t=16579

dramatically improved my FPS.

jrydun's Avatar


jrydun
12.14.2011 , 11:37 AM | #10
Thanks, turning shadows off literally fixed everything.