Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Game crashes before getting to character selection.

STAR WARS: The Old Republic > English > Customer Service
Game crashes before getting to character selection.

RhysM's Avatar


RhysM
01.09.2012 , 03:01 AM | #11
Thank god for this forum post. This worked for me thank you so much

Upplink's Avatar


Upplink
01.09.2012 , 04:53 AM | #12
Quote: Originally Posted by jhlundy View Post
Hey guys, I got up and running again with one of their suggestions:

1. Go to www.swtor.com/download
2. Download and launch the installer
3. Choose to reinstall over the current installation (it's fast)
4. Go to C:\Program Files (x86)\EA\Bioware\swtor and run fixlauncher.exe (also fast)
5. Launch the game, let the launcher patch itself, then log in
6. Go through the EULA and TOS again if prompted (and you should be good to go if you see these screens)

So I'm fixed, hope this helps folks with the same problem.


I went to that folder and there is no "Fix Launcher" Where is that supposed to be?

jhlundy's Avatar


jhlundy
01.09.2012 , 09:34 AM | #13
Running the installer again from www.swtor.com/download should put that fixlauncher.exe file into the program folder. If not, I would submit a tech support request because you probably have a slightly different problem than we're having.

Everyone else, glad to have helped. It was such a frustrating problem! Hopefully, BW can track down the underlying defect to keep folks from getting trapped in this problem.

Garythej's Avatar


Garythej
01.09.2012 , 10:57 AM | #14
*sigh* Still not working for me T_T any input anyone? 2 weeks without SW. Insanity is coming soon ._.

Scribbed's Avatar


Scribbed
01.09.2012 , 08:02 PM | #15
Anyone got an alternate fix? Still not working no matter what I try

EDIT
I simply reset my PC and it worked, so, feeling stupid, but it might help

NoRiceAllMac's Avatar


NoRiceAllMac
01.11.2012 , 01:18 AM | #16
Bump! Works like a charm

JJBattles's Avatar


JJBattles
01.11.2012 , 01:32 AM | #17
This didn't work for me. Any other suggestions?

Gorothlol's Avatar


Gorothlol
01.11.2012 , 02:15 PM | #18
Give this a shot:

Like many of you, I have had plenty of trouble trying to get this game running; from the blank server list to crashing to the desktop in the loading screen...you name it. After many days of troubleshooting and frustration, I figured out a fix. Heres what I did:

I had installed SWTOR to my Program Files (x86) in C: drive. Randomly, I decided to move the entire program over to my regular Program Files folder. Next I set the game to run in windowed mode (though im not sure if that had anything to do with it, because it was crashing before in windowed mode). I then made a shortcut from the luancher.exe file to the desktop. Ran the program as administrator and BAM problem solved, loaded up quick right to my character screen.

Hopefully this can help all of you having similar difficulties. I'll be checking back if anyone has any questions. Best of luck !

Ivomec's Avatar


Ivomec
02.20.2012 , 03:53 PM | #19
Thanks for this help, this fixed my issue completely.
Through the travail of the ages, Midst the pomp and toil of war, Have I fought and strove and perished Countless times upon this star.

Interositor's Avatar


Interositor
05.10.2012 , 07:36 PM | #20
The fix from this thread worked for me as well. Great advice.