Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Game crashes before getting to character selection.

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
Game crashes before getting to character selection.
 

Skroting's Avatar


Skroting
01.05.2012 , 11:22 PM | #1
So, when i press the play button, the game starts up, i get to see the loading screen, but before i get any further the game crashes.
I can see there's a message box appearing, but that closes itself before i have any chance at reading what the error message is.

Now this one here is a real treat, because i can't do anything about it, the game just closes down before i can do anything at all, there are no options to change, no workarounds as far as i know.

This all happened on my client after i've reinstalled the entire game twice, trying to fix the endless repair-loop bug, which i did eventually, but now i have the game-crashes.

jhlundy's Avatar


jhlundy
01.05.2012 , 11:28 PM | #2
I am encountering this same problem and was going to post info, but the sticky thread seems to be a crash "at character selection," not where we're describing it. After reinstall and updating, the movie plays, then crash to desktop. Subsequent launches, click Play, splash screen pops up, then crash to desktop a few seconds later.

EDIT: There are no crash dumps in $users\me\appdata\local\swtor\crashdump\swtor\

(Most current nVidia non-beta drivers, no system changes since yesterday, installing from DVD, will be trying the download installer again, but slow DSL makes this a highly impractical and time-sucking step).

DXD:
Spoiler


A couple of event log items:

Spoiler

GwydionAK's Avatar


GwydionAK
01.05.2012 , 11:29 PM | #3
Sounds like the same issue I'm having as well.

My thread in case it helps track down the issue.

E-Dubz's Avatar


E-Dubz
01.05.2012 , 11:33 PM | #4
Having the same issue!

jhlundy's Avatar


jhlundy
01.06.2012 , 12:17 AM | #5
Hey guys, I got up and running again with one of their suggestions:

1. Go to www.swtor.com/download
2. Download and launch the installer
3. Choose to reinstall over the current installation (it's fast)
4. Go to C:\Program Files (x86)\EA\Bioware\swtor and run fixlauncher.exe (also fast)
5. Launch the game, let the launcher patch itself, then log in
6. Go through the EULA and TOS again if prompted (and you should be good to go if you see these screens)

So I'm fixed, hope this helps folks with the same problem.

michaelpitt's Avatar


michaelpitt
01.06.2012 , 12:17 PM | #6
Wow thank god for this thread, spent the past two days trying to play after I formatted and reinstalled the game. Worked a treat muchos gracias!

Murkas's Avatar


Murkas
01.06.2012 , 12:48 PM | #7
Just tried doing what you wrote down, and it's working great!

Many thanks jhlundy!

NGF_Skag's Avatar


NGF_Skag
01.06.2012 , 08:56 PM | #8
still wont work for me.... thanks though most helpful one i found..

valorg's Avatar


valorg
01.09.2012 , 01:46 AM | #9
I actually just did a full on format and ran into this problem. what jhlundy suggested actually worked form. thanks

RhysM's Avatar


RhysM
01.09.2012 , 03:00 AM | #10
Thank god for this forum post. This worked for me thank you so much