Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Speeder decos

JediQuaker's Avatar


JediQuaker
08.23.2019 , 03:44 PM | #1
Has anyone else noticed some speeder decos** have gone missing? I seem to have lost 2 of the Noble Vanguard speeders, and I have a couple of empty spots I thought were filled.
But, it could be just me.

** I'm talking about the decos - placing them in a SH - not the speeders themselves. (Although I haven't yet checked that, come to think of it.)

Edit - just found one of the Noble Vanguards I thought was missing - so maybe it is just me - a senior moment.
Hold water, a sieve may not, but hold another sieve, it will - Yoda..

Referral code - http://www.swtor.com/r/dZ8wSV

TonyTricicolo's Avatar


TonyTricicolo
08.24.2019 , 10:03 AM | #2
Funny thing with mounts in general is that only the character that has the mount can place it. Case in point, I wanted to place a Zakuul taxi down and just couldn't find it. I was going crazy. I swear I have it because it's so big and memorable. I logged off then back on, nothing! Threw my keyboard around a few times, Then finally gave up. Ah well. It was only until later that by happenstance I was on a different toon fooling around decorating and low and behold there's my taxi!!
And on another note, if you place a mount down with one toon and pick it up with another then delete your first toon that owned the mount, the mount is gone. The exception being if the mount has been unlocked via collections. Decorations, on the other hand, are stored in your legacy pool. You can place it by any legacy toon and can delete the owner of the decoration.
TONY NOVA SWTOR Shadowlands/Star Forge
-STRYDER- SWG Sunrunner/SWGLegends
Referral Link: http://www.swtor.com/r/vNnj3G

JediQuaker's Avatar


JediQuaker
08.24.2019 , 11:36 AM | #3
I am aware of that.

It turns out that the 3 "Noble" speeders (from the LS vendor) were all there but they were scattered around in various places (in my Yavin 4 speeder/mount/pet SH). I moved them all together in the area where I thought they had disappeared from. That still doesn't clear up the fact that the spaces I used, I think used to already have some speeder or mount on them plus there seems to be some other spots that weren't empty before.

It has happened in the past that among other bugs after an update, some speeder/mounts have become invisible and or unplaceable, and/or removed.
I'm going to have to go through all my main characters and a few lesser alts that have some exclusive mounts, to see if any are missing from display on Yavin. (Some invisible ones could have been picked up when I placed the Nobles)
(Plus I've decided to expand my collection a bit by getting more mounts and pets from other reputation vendors such as the DS vendor, etc, that I haven't gotten yet.)
Hold water, a sieve may not, but hold another sieve, it will - Yoda..

Referral code - http://www.swtor.com/r/dZ8wSV

JediQuaker's Avatar


JediQuaker
08.24.2019 , 12:17 PM | #4
Update - it was just my imagination I guess. I just went through all my relevant alts and there's no missing speeder, mount, or pet decos.
Hold water, a sieve may not, but hold another sieve, it will - Yoda..

Referral code - http://www.swtor.com/r/dZ8wSV