Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

FPS issue can't be ATI


ryancwn's Avatar


ryancwn
01.17.2012 , 09:07 PM | #11
I owned both AMD and Nvidia, I don't have much trouble with both of them. I heard story about bugs etc on both camp from various review sites. The grass is not always greener on the other side.

yodimaster's Avatar


yodimaster
01.17.2012 , 09:10 PM | #12
Quote: Originally Posted by VoXPCS View Post
$20,000 over the course of 12 years. I know what I'm what i'm talking about.

Everyone can take it for a grain of salt for all I care. I've bought and I have owned , benchmarked it, overclocked it.

It's all cheap garbage on roll back from wal-mart.

People buy it because it's red, "cool looking" and cheap. Just like Apple products.

Makes me sad.
Lol nothing wrong with AMD/ATI just a bigger bang for the buck! Intel/nvidia are great but im not going to break the bank to get small improvements in gaming unless I go extreme on A 1K CPU for a few games! I still get around 90 fps on my 2yr old system!

Inraika's Avatar


Inraika
01.17.2012 , 09:13 PM | #13
Quote: Originally Posted by VoXPCS View Post
$20,000 over the course of 12 years. I know what I'm what i'm talking about.

Everyone can take it for a grain of salt for all I care. I've bought and I have owned , benchmarked it, overclocked it.

It's all cheap garbage on roll back from wal-mart.

People buy it because it's red, "cool looking" and cheap. Just like Apple products.

Makes me sad.

Still, it can't be all ATI cards... as posted in the topic starter.

Putok's Avatar


Putok
01.17.2012 , 09:20 PM | #14
I'm generally over 90 with my 5870 (with AA forced to 8x16, mipmap quality all the way up, texture filtering all the way up, etc), but I drop down to 30ish in the fleet. What's more, it doesn't seem to matter what my settings are like in the fleet, I drop down to 30ish no matter what.

Also 16BG of 1600MHz DDR3, PhenomII 965 OCed to 3700. Memory and CPU usage are both well, well below what they could be.

I have a feeling the game isn't utilizing as many system resources as it could be, for some reason.

Teldara's Avatar


Teldara
01.17.2012 , 09:20 PM | #15
I haven't tried benchmarking, but the game feels sluggish with crossfire on.

Sizzurps's Avatar


Sizzurps
01.17.2012 , 09:23 PM | #16
It's not the card(s). It's the engine which isn't optimized. It should be BW's top priority. Truth be told, BW should have licensed the Unreal 3 engine.
"All war is deception. - Sun Tzu

AMKSED's Avatar


AMKSED
01.17.2012 , 09:24 PM | #17
Game isn't optimized.

Fix? Wait a few months or so.

Gehoornde's Avatar


Gehoornde
01.17.2012 , 09:25 PM | #18
Nvidia = pro/elite gamer

AMD/ATI = poor people's choice

AMKSED's Avatar


AMKSED
01.17.2012 , 09:26 PM | #19
Quote: Originally Posted by Gehoornde View Post
Nvidia = pro/elite gamer

AMD/ATI = poor people's choice
Derp alert.

Putok's Avatar


Putok
01.17.2012 , 09:26 PM | #20
Quote: Originally Posted by Culveren View Post
I wonder if you are biased against AMD? LOL.
LOL indeed. Hardware fanboys are even more pathetic than computer game fanboys, because it really is all laid out in black and white with hardware, not much room for subjectivity.