Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Targeting monsters in NiM Bestia?

STAR WARS: The Old Republic > English > Classes
Targeting monsters in NiM Bestia?

Whojoo's Avatar


Whojoo
06.26.2014 , 12:16 AM | #11
Quote: Originally Posted by thewitchdoctor View Post
Can you (or another) explain this in more detail, please?
When holding the right mouse button you can move your camera. So he is talking about using ALT + C with the free camera movement from holding how the right mouse button.

Never knew about ALT + C, I have to try it when I am back home
The Red Eclipse
Republic Enforcers Suddenly Taken Over

thewitchdoctor's Avatar


thewitchdoctor
06.26.2014 , 06:13 AM | #12
Quote: Originally Posted by Whojoo View Post
When holding the right mouse button you can move your camera. So he is talking about using ALT + C with the free camera movement from holding how the right mouse button.

Never knew about ALT + C, I have to try it when I am back home
Ah! Yes. Thanks!
Good. Bad. I'm the twi'lek with the saber.
DPS: Carnage Marauder - Gunslinger - Sage
Tanks: Guardian - Juggernaut - Powertech - Assassin

AAAAzrael's Avatar


AAAAzrael
06.27.2014 , 04:01 AM | #13
I used your suggestions - it really works. Now do you guys use hybrid or full kinetic for this fight?
Ingalaarn Conqueror of the Dread Fortress / Ji'kiley Deposer of the Dread Masters
Gate Crasher Joshased / Xartanol From Beyond
Manticore @ The Red Eclipse

HBCentaurion's Avatar


HBCentaurion
06.27.2014 , 04:39 AM | #14
^^ Same.

Our assassin tanks the 2 adds and uses hybrid, while I'm on my PT (healing relic + hydraulics for kiting the monster to the tentacle).

BTW, last night I had some bad rendering issues on this fight. The monster would spawn, I could see them and target them, then when they moved close to the Throne they disappeared entirely from my screen. I could still target them, but the distance to target kept fluctuating from anywhere between 2m to 40m+. I thought it was LoS issues with throne, but when I moved to the back of throne, they were not there.

Anyone else have the same issue?

Whojoo's Avatar


Whojoo
06.27.2014 , 09:30 AM | #15
Quote: Originally Posted by HBCentaurion View Post
^^ Same.

Our assassin tanks the 2 adds and uses hybrid, while I'm on my PT (healing relic + hydraulics for kiting the monster to the tentacle).

BTW, last night I had some bad rendering issues on this fight. The monster would spawn, I could see them and target them, then when they moved close to the Throne they disappeared entirely from my screen. I could still target them, but the distance to target kept fluctuating from anywhere between 2m to 40m+. I thought it was LoS issues with throne, but when I moved to the back of throne, they were not there.

Anyone else have the same issue?
I forgot where, but I read about similar issues earlier today on the forum. Think someone also mentioned Bestia's adds.
The Red Eclipse
Republic Enforcers Suddenly Taken Over

jrwellworth's Avatar


jrwellworth
07.01.2014 , 10:36 AM | #16
That was me, I had big issue's with this in HM bestia, and it was terrible, I have since started using the method of leaving the team in the hall, running in and pulling Bestia, and dying and being rezzed in instance. It helps, also the new rez in instance at start has helped me. The dropping into the ground thing is awful though. It's happened in dread entity, Bestia, and dreadtooth. I don't know why this happens, but I think I need to water my hamsters more.
Sandari-60 (kinetic combat) +more <Aeternium Ascension>
<Sith Praxium> B.C. Dread Slayer

.

Leafy_Bug's Avatar


Leafy_Bug
07.08.2014 , 12:59 PM | #17
The cherry on top is when an add goes 300m away from my co tank, he can't tank it, but we can all hit it and see it kill healers