Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Toggle Sound

brlarson's Avatar


brlarson
01.01.2014 , 06:46 PM | #1
I unbound the Toggle Sound hotkey a long time ago, I just double checked and it isn't bound a any keystroke, but when I am in a GSF match my sound toggles off several times during each match. This is extremely annoying as I usually play a strike fighter and I am unable to hear the beep to indicate a missile lock and therefore miss chances to fire them. What's worse is that when I hisc to turn the sound back on before I respawn, sometimes it closes the respawn window and I can't figure out how to bring it back up. Subsequently I am forced to either quit the match and miss out on the experience and requisition points or stare at the last thing I saw before I was killed until the match is over.

Has anyone else experienced this? I looked through the Galactic Starfighter tab in Keybindings and didn't see a Toggle Sound option there...

jankiel's Avatar


jankiel
01.01.2014 , 07:05 PM | #2
Quote: Originally Posted by brlarson View Post
I unbound the Toggle Sound hotkey a long time ago, I just double checked and it isn't bound a any keystroke, but when I am in a GSF match my sound toggles off several times during each match. This is extremely annoying as I usually play a strike fighter and I am unable to hear the beep to indicate a missile lock and therefore miss chances to fire them. What's worse is that when I hisc to turn the sound back on before I respawn, sometimes it closes the respawn window and I can't figure out how to bring it back up. Subsequently I am forced to either quit the match and miss out on the experience and requisition points or stare at the last thing I saw before I was killed until the match is over.

Has anyone else experienced this? I looked through the Galactic Starfighter tab in Keybindings and didn't see a Toggle Sound option there...
Are you using XP? Because there is a bug for win XP in which players loose sounds during GSF matches.

brlarson's Avatar


brlarson
01.01.2014 , 07:19 PM | #3
I'm usind Windows &. I read about the XP bug, but those players describe losing sound at the beginning of the match. Mine simply toggles off when I use certain abilities during the match.

DanNV's Avatar


DanNV
01.01.2014 , 07:58 PM | #4
Not sure if it's still an issue, but during testing some of the keybinds are there even if you removed them. So, if that keybind is hard coded into GSF< you've got it and could be turning it on and off yourself.
Quote: Originally Posted by Rion_Starkiller View Post
Devs gambled everything on GC RNG, but they didn't even get green loot.
REGULATORS

brlarson's Avatar


brlarson
01.02.2014 , 02:11 AM | #5
That seems to be the case. I'll have to rebind my abilities to different keys. Thanks for the response.

Sadishist's Avatar


Sadishist
01.02.2014 , 03:39 AM | #6
I have the same problem when I keybind the power converters to Ctrl+1/2/3/4 on my Logitech MMO mouse. Using Win 8.

Itkovian's Avatar


Itkovian
01.02.2014 , 07:48 AM | #7
By default the sound toggle is set to CTRL-S, and there is a bug in GSF which keeps the toggle there regardless of what else you set it as.

Therefore, if you use CTRL for anything (I use it as my voice chat's Push-To-Talk button), you WILL toggle your sound on and off periodically as you press both CTRL and S.

This is a bug, as GSF should respect the "Toggle Sound" keybind.

Hopefully it will be fixed shortly, as it is quite annoying.