Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Missile Lock woes: bugged or working as intended?

STAR WARS: The Old Republic > English > Galactic Starfighter
Missile Lock woes: bugged or working as intended?

BobBudJones's Avatar


BobBudJones
02.21.2014 , 09:52 PM | #1
I read this comment in another thread (http://www.swtor.com/community/showt...02894&page=5):

"The missile lock is an especially bad aspect. I've bought all the reduced lockon time upgrades possible on several of them, and they still randomly stop tracking despite the target never leaving the middle of the aim circle. When I get TONE to tell me I'm locked, it's hit or miss whether any missiles actually fire when I release. I finally realized that SOMETIMES they are firing but playing no visual, but sometimes they just don't fire despite hearing a lock and the target never getting out of my fire zone. Clearly I'm doing something wrong, because other players seem to have NO problem at all getting lockon in amazingly short times." [Courtesy of The_Hunter_Too]

I have EXACTLY these same problems. Lock-on process interrupts for no apparent reason (no defensive moves triggered, target still centered), and then the bit about missiles not firing when I release the button after a successful (supposedly) lock. Again, targets are still in range and no maneuvers/cooldowns have been executed. I have the same problems with Sabotage Probes also.

Am I screwing up or is something broken here? Both problems seem to happen quite frequently.

Sindariel's Avatar


Sindariel
02.21.2014 , 10:43 PM | #2
I have this problem, too.
Some people say it's due to server lag, however, how can it be lag when the target never leaves my aiming circle or my lock-on range?

MystbladeWA's Avatar


MystbladeWA
02.21.2014 , 10:56 PM | #3
I have similar issues now and again.
Hold'My'Beer Chill
I'Got'This Legacy

OscarDivine's Avatar


OscarDivine
02.21.2014 , 11:07 PM | #4
I have encountered this as well, to a degree. You should also realize that a projectile like the Photon Torpedo travels VERY slowly unless you have the speed boost on it. You can literally outrun your own missile and hit your brakes, then watch it fly past you.

If you use a super fast projectile like a concussion missile or a cluster missile, you shouldn't notice this so much.

I've found that while using Photon Torpedoes, the "failure to launch" problem usually happens while I'm firing lasers at the same time as releasing my lock. I may be wrong though. I've got some vid cap of this happening as well as a vid cap of random lock breaks for no good reason.

BobBudJones's Avatar


BobBudJones
02.21.2014 , 11:52 PM | #5
FWIW, I use mainly concussion and cluster missiles. But yeah...now that you mention it, I usually am firing lasers at the same time. You should be able to do that though....

It could be lag if the ship in fact gets outside your firing arc but the lag causes it to appear inside it....in that case maybe it should be a little less sensitive? I dunno.

DroidDreamer's Avatar


DroidDreamer
02.22.2014 , 02:10 AM | #6
Quote: Originally Posted by Sindariel View Post
I have this problem, too.
Some people say it's due to server lag, however, how can it be lag when the target never leaves my aiming circle or my lock-on range?
Same here. Very frustrating.
The DroidDreamer Legacy (Pot5 Server)
Eblen 50 Sorc heals | Sodan 50 Sniper | Trilliant 37 Immortal Jugg | Somnis 50 TankSin
They mark me with the lightning bolt in Huttball.

Markviper's Avatar


Markviper
02.22.2014 , 03:39 AM | #7
The seemingly random lock drops are lag between you, the server, and your target. Your client sees the target in the arc properly, then the server tells it "No it's actually here" which is just outside of your arc, and the lock breaks. They just need to change it where the lock is dependent on if your client sees the target properly in the arc.
Markviper Guardian tank
Marthaviper Shadow tank
Headbash Commando
Peterwigin Gunslinger
Herpderpsmash Sentinel
Lilandriakin Sage
Projectbeta Powertech tank

Slivovidze's Avatar


Slivovidze
02.22.2014 , 03:46 AM | #8
If it is lag, I may want an explanation of why I am still hitting the dude with my lasers, inside my Thermite 16 cone, and yet the Thermite loses the lock.

Sometimes it really bugs me.

Umbradomina's Avatar


Umbradomina
02.22.2014 , 05:34 AM | #9
Don't forget the defensive buffs that break missile lock. That could be part of the issue.
Old age and treachery will usually win out over youth and skill.

Jandi's Avatar


Jandi
02.22.2014 , 05:41 AM | #10
Quote: Originally Posted by Umbradomina View Post
Don't forget the defensive buffs that break missile lock. That could be part of the issue.
Yeah, scouts have that at least that break all locks but I don't think that's it. Sometimes, and only against certain people it seems, a missile just won't lock on, it just ends for literally no reason again and again while working fine against others in the same match.

Oh and I have a stable 62ms ping so I'm certain it's not on my end, but beween the server and the person I'm trying to lock on to.