Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Lack of performance patches - disappointing

STAR WARS: The Old Republic > English > General Discussion
Lack of performance patches - disappointing

sjmc's Avatar


sjmc
03.19.2012 , 05:00 PM | #251
Quote: Originally Posted by coolsamme View Post
Dear.. This game runs better on worse computers because low end and mid end computers RUNS the game normally, while high end computers enchants the game and makes it better at every aspect, which SWTOR isn't optimized for. I play BF3 on ultra, with 200 FPS, same with Skyrim. No, it's not my computer.
Are there really monitors that can display 200 FPS?

Nojo's Avatar


Nojo
03.19.2012 , 05:18 PM | #252
What about the load screens? OMG the load screens. My system loads Mass Effect 3 scenes in 3-5 seconds, it takes 3-5 minutes for me to load into a higher level planet in SWTOR. Even Alt-Tabbing away and coming back takes 15+ seconds to display again. I'd be embarrassed if I designed this engine.

Fiesbert's Avatar


Fiesbert
03.19.2012 , 07:02 PM | #253
Quote: Originally Posted by Nojo View Post
What about the load screens? OMG the load screens. My system loads Mass Effect 3 scenes in 3-5 seconds, it takes 3-5 minutes for me to load into a higher level planet in SWTOR. Even Alt-Tabbing away and coming back takes 15+ seconds to display again. I'd be embarrassed if I designed this engine.
Thats another hint for something being wrong with the game client.

Lord_Ravenhurst's Avatar


Lord_Ravenhurst
03.19.2012 , 07:19 PM | #254
Quote: Originally Posted by Nojo View Post
What about the load screens? OMG the load screens. My system loads Mass Effect 3 scenes in 3-5 seconds, it takes 3-5 minutes for me to load into a higher level planet in SWTOR. Even Alt-Tabbing away and coming back takes 15+ seconds to display again. I'd be embarrassed if I designed this engine.

Yep, feels like 2003 or even earlier. I remember PS2 games with similiar graphics loading faster.

and my PC is top spec plus Raid 0 HDs

scootshoot's Avatar


scootshoot
03.19.2012 , 07:31 PM | #255
Shadows absolutely destroys the FPS in this game. Regardless of the system you have, if you doing demanding "instances" like Warzones which in itself is laughable considering it's only 8 on 8 and the graphics of this game is not even that good, turn Shadows OFF

Red_Vs_Blue's Avatar


Red_Vs_Blue
03.19.2012 , 07:36 PM | #256
i5 750K, with amd radeon 6850. Less fps than i got back when i had BF3 (got my refund, game sucked arse back when it launched). but i still can get 20-30 fps on high. Kinda lame seeing as in wow i got 60-70 fps on ultra, and both graphics are honestly the same.

scootshoot's Avatar


scootshoot
03.19.2012 , 07:40 PM | #257
Quote: Originally Posted by Red_Vs_Blue View Post
i5 750K, with amd radeon 6850. Less fps than i got back when i had BF3 (got my refund, game sucked arse back when it launched). but i still can get 20-30 fps on high. kinda lime seeing as in wow i got 60-70 fps on ultra, and both graphics are honestly the same.

Ditto. Could you imagine this direct X 9, 2012 release MMO trying to pull off a 40 on 40 Alterac Valley? lol

Servers would crash,

Red_Vs_Blue's Avatar


Red_Vs_Blue
03.19.2012 , 07:49 PM | #258
Quote: Originally Posted by scootshoot View Post
Ditto. Could you imagine this direct X 9, 2012 release MMO trying to pull off a 40 on 40 Alterac Valley? lol

Servers would crash,
Funny thing is, i am sure AV launched back around when DX9 was also around, or perhaps it came later (i don't know), it still ran fine. I even recall having a pretty epic fight on my older pc, sure it had some hiccups and what not (by old i mean it still runs on a Pentium processor and i believe it has an on board video card), but i sure had better fps.

Eh, i miss WoW from time to time.