Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Re: Issue logging into swtor

Rujadah's Avatar

06.22.2014 , 06:12 PM | #1
Fellow players,

I am having an issue logging onto SWTOR that both Bioware and Cox Communications can't seem to figure out whats going on, and keep pointing their proverbial fingers at each other.

I recently updated my computer to a Intel Core i7 4771 processor, with 16 GB RAM, and am running Windows 7 64Bit. I have tried to Run as Administrator and run using Windows XP Service Pack 2. I also ran the troubleshooting software fm SWTOR to choose the best compatibility to use (which is Windows XP Service Pack 2).

I can get to the load in-screen, put my user name, password, and security key. It updates with the latest patches, etc, BUT, when it goes to play my computer totally locks up and I can't use the mouse, keyboard, etc, and have to hard reboot the computer (I left it like that for 10 minutes to see if it caught up).

When I "pinged" the IP, and ran a tracert, both came back saying that my signal drops off in Dallas. I called Cox and they said they can't reroute the signal to get me a stronger signal, and they said this was a Bioware issue not theirs. When I contacted Bioware and reran the tests, they said it was a Cox issue and not theirs. So basically I am paying for a game I can't play and neither Cox or Bioware can (or are willing) to help me.

I have been in contact with you guys for the past 2 months, it is getting extremely frustrating. I have been part of SWTOR since day one, and still pay for it even though it is free-to-play. Someone there has to have a suggestion for me besides telling me it is a Cox Communications problem.

So, I am sending this out to my fellow players, hoping maybe one of you can help me figure this out. I know that the game is Free to Play, but I like to support the community (and economy) and I like getting the free Cartel Coins.

Thanks for your time and assistance.

Gene (aka Jersey)

MadMacavelli's Avatar

06.22.2014 , 07:17 PM | #2
are you on the east coast ? ..if so ..during peak times ive found ..just today ..that D.C. gets clogged and that's the issue , I know on the west coast there is a clog near cali ...and its not my isp ..its junction points in between

Rujadah's Avatar

06.23.2014 , 09:06 AM | #3
I am in Arizona, and for whatever reason I drop off at the Dallas area junction. No one knows why that is or assist me with bypassing that area.

Sinzhareth's Avatar

06.23.2014 , 09:09 AM | #4
Is there by any chance you are using WI-Fi? Try connecting with your router with a cable or something and see. If you downloaded the game to your computer, then there is no need to change compatibilities to Windows XP Service Pack 2 and just run it with Windows 7 OS behavior. This method only applies when you copy pasted the client from another computer that has a Different OS.

Example: You got a Client SWTOR File from a Windows XP Computer and pasted it with your Computer with a Windows 7 OS. That's the time you change compatibilies.

Anyway, its kinda weird that you are having issues connecting to thegame, and I'm outside US, currently somewhere Asia, and I don't have any issues or whatsoever connecting with the servers. I believe that it could be the wi-fi that messing with you since it is strongly recommended to play MMO Games with a cable not wi-fi. If you are using a Cable, not wi-fi, then I don't know. > w < Good luck~!

Rujadah's Avatar

06.27.2014 , 05:36 PM | #5

The computer is hooked into my router via a cable. I don't know why I am having this issue, both Cox and Bioware are saying the fault lies with each other. I've called Cox and asked them to route me another way and I was told they can't do that. Frustrating. I can log in to the game via my Laptop (wirelessly).


Pavo's Avatar

06.27.2014 , 06:23 PM | #6
You know I recently had a similar issue. I too was having my computer completely freeze when I tried to play. I could not get to the character screen inside the game. I called into SWTOR's customer support and they walked me through downloading a version that was not their "streaming" (I think I'm saying that correctly) one. Their suggestion completely fixed my problem. I am uncertain if this helps, but maybe it's worth a shot.

johndoeb's Avatar

06.27.2014 , 07:49 PM | #7
Just remember it will mean a complete re download of the game. The only advice I can offer is when you get it working you might want to make a complete backup of all the game files. There seem to be a an issue with the game; Bio ware know about it.,but it is hard to fix. You can try what the last player suggested some people seem to have luck with that for awhile , but the same problem will return. In case you are interested in what the problem is I have included a link that is the best explanation of what the problem is.