Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Whats wrong with my CPU?


MisterData's Avatar


MisterData
03.12.2012 , 05:42 PM | #21
Quote: Originally Posted by NessusFett View Post
Yeah regardless of brand, a 6core is beast mode...
why you went with the 550 makes me scratch my head though..
especially when the 560s are noticeably better and only $250
I just got a 560ti for $199 after rebate

blowmedown's Avatar


blowmedown
03.12.2012 , 05:46 PM | #22
Quote: Originally Posted by KatPhish View Post
canned air. my wife is always bringing me home some that she "picks up" from work. i use it alot to get all the dust out. sometimes i use a vacuum cleaner, (keeping the actual vacuum as far away from your PC as possible) and use the hose. I bet your graphic's card fan is full of dust, but just give your whole computer a through cleaning. you could say i have OCD but i clean my PC at least twice a month. the cooler it is the smoother it will run.

Dirty computer

I would not recommend using a high powered air hose like he does in the video though.
Always hold the fan still when using air for cleaning it can burn out your bearing/sleave in the fan by turning to many RPM's when you do that.

Viscidslime's Avatar


Viscidslime
03.12.2012 , 05:53 PM | #23
You can always negotiate your rig right up next to an AC unit in your window.. super cooling system for 2 purposes

Krewel's Avatar


Krewel
03.12.2012 , 06:10 PM | #24
Well, I have phenom II x4 925 and gtx 560 Ti and it really seems this game hates AMD CPU for some reason (Hero Engine for the lose), I get around 10-15 fps during fights in 16 man EV and KP, 20 in WZ, Ilum is not even worth mentioning on Very Low settings, it's simply obnoxious, if I weren't a big fan of both Star Wars and Bioware, I'd throw this game in the trash heap. Sure, the fps are good when it comes to levelling and 4 man content, but what about real MMO stuff, like Warzones, Fleet, 16 man raids and Ilum - pretty much unbearable performance. Not only that, I have my task manager and cpu-z open all the time to measure cpu usage during terrible performance and guess what - the game only uses 70% of cpu max, it's like it doesn't even know I have quad core inside. And GPU intensive? It's pretty much sitting at 50% gpu usage, my 560 Ti is sleeping.

Every other game runs perfectly on my system, Mass Effect 3 with Unreal Engine 3.0 having much better graphics than the cartoony SWTOR runs like a charm - 60+ fps all the time, but SWTOR pretty much demands i5 2500k (possibly even overclocked) to get high fps on High settings. This game baffles me on so many levels it's not funny anymore. Outdated graphics and unoptimized engine demanding expensive rigs to run it - not a very good attraction for potential customers, one of the reasons WoW is/was so successful is because it can run on toasters.

KrimzonWarrior's Avatar


KrimzonWarrior
03.12.2012 , 06:11 PM | #25
Actually now that I read more about your chip, it isn't all that comparable to mine. Mine is a Phenom II X6 1055t, a hexacore, while your model is actually an unlocked 960t. Not a true hexacore.

Krewel's Avatar


Krewel
03.12.2012 , 06:12 PM | #26
Quote: Originally Posted by KrimzonWarrior View Post
Actually now that I read more about your chip, it isn't all that comparable to mine. Mine is a Phenom II X6 1055t, a hexacore, while your model is actually an unlocked 960t. Not a true hexacore.
And why would that matter for this outdated and unoptimized game? SWTOR doesn't even know how to use 4gb ram, let alone quad core

Tiek's Avatar


Tiek
03.12.2012 , 06:13 PM | #27
having 6 cores doesnt really mean anything to swtor.. and the 550ti can and does run this game at 80-100fps.

screen res could have something to do with it, at 1680x1050 i have all graphics turned up except shadows and the only place my framerate stutters at all is a busy area on the fleet.

you didnt mention what your screen res was, or i missed it somewhere.

KrimzonWarrior's Avatar


KrimzonWarrior
03.12.2012 , 06:14 PM | #28
The game has awful optimization, but it has def improved since launch. My AMD rig used to get like 5-15 fps in fleet and somehow LESS in warzones. Now I am at 20 fps fleet and well above 30 in Warzones, with 45-60 in everything else.