Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

SWTOR Launcher has stopped working

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
SWTOR Launcher has stopped working
First BioWare Post First BioWare Post

Deathgirll's Avatar

07.26.2013 , 01:11 AM | #601
Writing from my daughter's account. She insisted on coming back to this game after getting bored with Warcraft, and I followed. We have both experienced the login problem. She is now a paying subscriber, but had the problem before she started paying, and not after; a coincidence? But even then, if she tried a few times, she could get in. But starting a day or two ago, I cannot get in at all. Most of the time, I can't even logon to the loader without the loader crashing. When I can get to the point of starting a repair, it runs for a long time then crashes before finishing. Then I can't logon to the loader until deleting the files suggested previously. So the patcher appears to corrupt itself.
I hate the official responses that complain about my hardware, no hardware has changed here and every other game still works without a problem. We both use older XP machines which are completely capable of playing these games. Her system has always had the graphics glitch where if she is ever inactive for too long an it logs out her character, some backgrounds flash until she reboots. My system is usually more stable, but now I can't even play the thing. It's disgusting that Bioware keeps causing more problems with their constant patching, hard to believe with this "mature" of software. This BS is a good part of the reason why we stopped playing before, and I'm sure not going to pay for a game that doesn't work when I have lots of other options, even if it makes my little girl sad. And she won't last another month without me playing. At this point, its not like I have a choice. I have little time and no money to throw at Bioware's problems. Maybe it'll fix itself tomorrow?
Way to go guys! Otherwise I enjoyed the game.

Followup - I deleted EVERYTHING in the game directory and copied ALL the game files from Daughter's machine to mine, and it works again! So yeah, your patcher or repair program is corrupting the game. Please deposit free game time for debugging your scat. Thanks for the graphics card advice, but its happens with two different cards, many drivers, seems to be an issue with her cheesy Foxcon motherboard, occurs with no other software, and isn't a big deal compared to the login problem.

OwenBrooks's Avatar

07.26.2013 , 01:14 AM | #602
If one system is patching ok, copy the game folder to system that isn't, less stressful method to get up and running again.

For daughters Post up her dxdiag and can check if anything is amiss, flashing gfx is normally tied to the video driver, and needing to reboot to clear the issue is a good indication.
Can also try deleting the DiskCacheArena file if you have already run the repair on the launcher , in case it has corrupted somehow.

ComandoScorch's Avatar

07.27.2013 , 09:14 AM | #603
My launcher will start up fine and when it gets to 8% of the update, it'll say, "Detected problem with Star Wars The Old Republic Launcher" it's been like this for a few days now and I need a way to fix

OwenBrooks's Avatar

07.27.2013 , 09:17 AM | #604
Quote: Originally Posted by ComandoScorch View Post
My launcher will start up fine and when it gets to 8% of the update, it'll say, "Detected problem with Star Wars The Old Republic Launcher" it's been like this for a few days now and I need a way to fix
Page 59 -

This is the official response
Quote: Originally Posted by Naugor View Post
Heya everyone,

Thank you for assisting us with the requested files, we are still investigating the issue. If your launcher continues to crashing at 8% while processing the main assets files, we would like you to do the following for now:
  1. Close the launcher
  2. Delete the "swtor_main_anim_creature_npc_1.tor" file located in "Assets" sub-folder of your Star Wars: The Old Republic installation folder, as suggested by Lord-Seath (thanks!).
  3. Delete any patch subfolders currently in your Star Wars: The Old Republic installation folder:
    • "Patch" folder
    • "Patcher_-1toXX" or similar folders
  4. Re-start the launcher and let it "Repair" when prompted.
  5. Finish the patching process
If you are still encountering issues afterwards, close the launcher, delete the "assets_swtor_main_version" file in the subfolder "Assets" as CoLatrLdamage (thanks!) had pointed out and re-start the launcher.

Please note that we cannot endorse downloading files from third-party websites. While used with the best of intentions, we cannot guarantee these files to be of pristine condition and as described above this step should not be necessary.

We would like to apologize for any inconvenience and thank you for your patience and understanding.

BraedenW's Avatar

07.27.2013 , 10:27 AM | #605
Whenever I try to start the game, the launcher loads up fine... but, after I put my account info in I get an error, I have tried all troubleshooting problems and nothing seems to help, this is the error I continue to get ; The patcher service is currently unavailable. Please visit our Forums for the latest updates on the status of this service.
Any ideas of how to fix this?

timeisrough's Avatar

08.02.2013 , 08:26 PM | #606
Dude I can't even find my assets folder or a installation folder

SwiftDuck's Avatar

08.17.2013 , 08:58 AM | #607
Im getting this issue on the PTS launcher. Im getting irritated as it freezes up my entire pc. This needs a fix ASAP no more ignoring it bioware.

OwenBrooks's Avatar

08.17.2013 , 09:07 AM | #608
If this is just the PTS it is occurring on , try deleting the file called retailclient_publictest.version

SwiftDuck's Avatar

08.17.2013 , 09:13 AM | #609
Quote: Originally Posted by OwenBrooks View Post
If this is just the PTS it is occurring on , try deleting the file called retailclient_publictest.version
I will try that thank you.