Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Heroic Space Missions are Bugged!


Seagro's Avatar


Seagro
04.03.2013 , 05:33 PM | #1
the blaster does not read the correct amount it reads 30 when you un equip it it reads 100 , but still does not have the out put it should! what is up with this ?

PhineasRay's Avatar


PhineasRay
04.03.2013 , 09:36 PM | #2
This is what I came onto the forums for today! I've had the same problem. It even happens with the grade 7 blaster in the non heroics. And it's been like that for a few days.

Leovinus's Avatar


Leovinus
04.04.2013 , 07:36 AM | #3
Quote: Originally Posted by Seagro View Post
the blaster does not read the correct amount it reads 30 when you un equip it it reads 100 , but still does not have the out put it should! what is up with this ?
You should, perhaps, look at the multiple other threads on this very topic over the last week or two. Including one with a reply by a dev stating that it's fixed in 2.0.

LarryRow's Avatar


LarryRow
04.04.2013 , 07:46 AM | #4
Use the beam generator that is one level below grade 7. You should be able to complete all the missions with only slightly more difficulty than normal.
A classic sig that should not be lost:
Quote:
Stunned , pew pew hack slash , stunned , running backward circles, stunned cannot move, pew pew, break stun, 30 second snare, wha?!?!!? stunned, knockdown, ...less stun more pew pew and hacknslash please.

Seagro's Avatar


Seagro
04.04.2013 , 08:20 AM | #5
it is not the beam generator it is the rendi and can only be gotten in from completing a one time mission and I sold it when I Upgraded to the 7 blast condensor!

Darevsool's Avatar


Darevsool
04.04.2013 , 08:31 AM | #6
you can buy a grade 4 from the GTN, it will work as well.

Seagro's Avatar


Seagro
04.04.2013 , 08:51 AM | #7
yes you can get the 4 but the missions are hard although I have completed them all some of them will but out of the ? with the level 4 like the thorium one!

mattchanner's Avatar


mattchanner
04.04.2013 , 10:26 AM | #8
I unequipped everything on my ship. put on a rank 5 beam charger. replaced it with grade 7 and it went to 100 dmg then i put everything else back on. worked. so try unequipping and equipping shiz until it works.

Also did anyone else notice that the grade 5 beam generator is better then the grade 7 one?
grade 5: 9 shots per second
grade 7: 6 shots per second
U MAD? Let go of your Anger.
Look I made a Dumb fan video too
http://www.youtube.com/watch?v=USRec...el_video_title

Kitru's Avatar


Kitru
04.04.2013 , 01:06 PM | #9
Quote: Originally Posted by mattchanner View Post
Also did anyone else notice that the grade 5 beam generator is better then the grade 7 one?
grade 5: 9 shots per second
grade 7: 6 shots per second
The Blast Condenser (grade 7) is *supposed* to fire fewer shots because, before 1.7.3 dropped, it also increased damage of your blaster bolts by 100. Basically, it was designed to provide fewer shots while doubling the damage said shots dealt (6 shots with double the damage is better than 10 shots with standard damage). The problem is that, for some reason, the Blast Condenser somehow lost the blaster bolt damage increase and got it replaced with that instead reduces your damage dealt (though this replacement effect is hidden).
Walls of Text? I *love* Walls of Text!
My New Class Idea
Shadow Class Rep - Suggest/Review Questions Here
Quote: Originally Posted by Fende View Post
Listen to Kitru. Kitru knows all.

Waasiq's Avatar


Waasiq
04.04.2013 , 03:40 PM | #10
Same here I think either it is bugged or bio ware nerfed it on purpose so we have to buy new ship equipment from cartel market when they introduce (That is if they introduce it) Money making scheme !!