Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Quest: Number One with a Bullet

STAR WARS: The Old Republic > English > Classes
Quest: Number One with a Bullet

nazbit's Avatar

02.25.2013 , 06:41 PM | #81
Quote: Originally Posted by NULL_ARC_ELEVEN View Post
I would one day like to complete this quest. This is the only quest left to do, and there is just no way I can get this beat.

Why haven't they fixed this yet?

Edit: Ive been waiting for a fix to this since release...
you need to keep them away from each other P.S use mako

Valefor's Avatar

02.27.2013 , 06:48 PM | #82
Im surprised this thread is still going. When I originally posted it was at the release of SWTOR and I was level 50 at the time in Corellia commendation gear plus random greens/blues etc. This was before the changes to talent trees / class / free tionese gear and so on, all vanilla SWTOR.

As many of you know Powertech does not have a long CC ability so it makes the fight difficult. In the end I just kept on trying and was successful with a nuke and lucky critical hits.

Then I hit the bug where I was not given "First Strike" and was unable to proceed to ilum quest line and missed out on the daily quests until they fixed the bugs, I still to this day do not have an interlude screen for completing the Bounty Hunter story line. I expect to see the Chapter 3 founder details every time I log in until the end of time as its been forgotten.

PS. I want that $100

Dinoviking's Avatar

03.13.2013 , 05:15 AM | #83
I'm actually not at all surprised this thread is still going. I'm not surprised because the quest is still in desperate need of a serious nerf. I understand that many mercs have done this quest and moved on. Unfortunately it is tuned as such that PT has a really hard time with it. There are those who would say it's the player's fault and make wonderfully helpful comments such as "you're doing it wrong", "L2P newb", etc., but it isn't necessarily true. I have tried the separation trick, trying to grapple one to keep him away from the other. Supposedly, if you grapple one from far enough away, the other one stays out of the fight and you can burn them down one at a time. I have tried this trick over a dozen times and it has never worked. Whoever did it got lucky. I have tried every companion at least once to see if a change in strategy will work. It doesn't. I tried the "send a tank companion and the close the airlock" trick. This supposedly ends the fight immediately and you can move on without fighting them at all. I tried this, and all I got was a broken quest that would not allow me to continue. It bugged out completely and I had to leave and start over.

None of the supposedly effective methods of beating this fight have worked for me. The only conceivable way for me to finish my BH story is to hire somebody to help me with it. This is just plain wrong. I should be able to solo this quest. I'm not saying make it a cakewalk, that would be the opposite problem. I don't want it to be too easy. Problem is, they way it is now, it's too hard for a significant number of people. They need to nerf it. I know the perfect way to do it too. Simply remove the heals. They already have more hp than normal strongs. They already hit like trucks. They don't need chain heals too. Just remove them. Problem solved.

There are those who would disagree with this and say that it would make them too easy. I, for one, would rather they be too easy for some, if that prevents them from being impossible for others as they are now. Certain specific combinations of spec and gear can get past them. Everyone else is getting slaughtered. The fight definitely favors merc over PT and that's not right either.

Keep in mind this is just my opinion. If nothing happens to change this fight, I will probably never finish the BH story. Ever. It's just too hard. I'm sure BW is aware of this, this isn't the only thread I've seen on the issue, I'm just not sure they care. To those who disagree with me, fine. You are entitled to your opinion and I'm not gonna say you're wrong. I just want those people to realize that there are a lot of us out there having a problem here, and the fact that they didn't doesn't change what we're going through. The fight needs a change. If you are so awesome a player that you beat it without an issue, well, good for you. Seriously. That's not sarcasm or bitterness, I really mean it. Congratulations, you earned it. The rest of us need help and we're not getting it.

Just my 2 credits.

Have a nice day.
LFG Fippy Darkpaw. PST.

Koyaanisqat's Avatar

03.13.2013 , 04:56 PM | #84
Even if you don't have a mez as a Powertech, Mako does (kinda), and Powertechs have an interrupt (Mercs didn't when I beat this quest I can't remember back in week 1 of opening). If you've gotta pop heroic moment to double-up the electro-dart, do so.
Elgyn Vriess, Space Pirate of the KDY-MANTIS Amelia, HYPERSPACE LEGEND.
Courier at large; Mercenary at small.
Elgyn Vriess Courier Company: When you need tab A inserted into slot B without C getting in the way. No questions asked (besides, "What'll it pay?").

VeggieRonin's Avatar

06.26.2013 , 02:46 AM | #85
Well this quest is still a problem. I am a pyro merc. The room is completely black you can't see a thing and the guards 'pop in' when they aggro (they are invisible before you can't see anything in the room), and I don't see any pod to enter - nothing visible to click. My CC just doesn't work on either mob and my companion can't damage either Larrot or the other Crisis Response mob. I have used heroic moment and thrown down legacy lightning storm and orbital strike and they don't take damage. I can hurt the one guy with only a few of my attacks. I am in partial Black Hole gear, level 52, and all my armoring is 140 rating or better. Just spent over 15k on repairs running this thing - must be bugged is all I can think of. I've got 3 other chars level 50+ and I don't remember this much trouble when I did it as a powertech. Without question the least fun I've had in this game in almost 2 years. Frustrating. Hope customer service responds to my ticket because this is horrible....
The Austrian-econ Legacy. Server: The Harbinger, The Shadowlands

VeggieRonin's Avatar

06.26.2013 , 10:16 AM | #86
well....on my third log in/out all of a sudden the quest was complete and I was back near my ship airlock. [shrugs]
The Austrian-econ Legacy. Server: The Harbinger, The Shadowlands

CloudCastle's Avatar

08.30.2013 , 10:29 PM | #87
I can't tell if I'm missing some critical step in this quest, or if I'm bugged. Has anyone else had the room with Larrot be totally black? I can't see a thing in the room, not the walls or even the mobs, unless they are specifically targeted. (And then I can only see their name plates.) At one point all my skills went gray as if I were stunned, but when I tried to use my escape skill (determination), it told me I was not incapacitated. By that point, Larrot had practically healed up completely and I was at low health. Even when I do manage to kill one of them, the second simply heals himself up faster than I can burn him down, and then I die. Then the whole thing resets and I have to kill both of them all over again.

I am a powertech, tank specced, using Torian. I've read this thread but I'm still stuck. Is the room supposed to be totally dark?

CloudCastle's Avatar

08.31.2013 , 11:22 AM | #88
Well, the same thing that happened to the poster above me, also happened to me. I logged on today, and the quest door is red and the log is telling me that I successfully escaped from the ship. Did I miss a cut scene that showed me escaping in the pod? I'm a little disappointed that I never did get to beat this fight, but at least I can move on I guess. Very odd. Seems buggy to me.

Yamirra's Avatar

06.01.2015 , 08:48 AM | #89
I am a healing merc but you really do need a healer comp if you're going to interrupt properly and stay alive at the same time. Busted the Supreme Guard after using Mako and I half-DPSed and half-healed throughout the fight. It was really easy.
Arakhne Srei'yr: Level 60 Jedi Guardian
Nyassha Bren: Level 60 Jedi Sage
Vythica Q'pala (Lord Iron): Level 60 Sith Juggernaut
IzabÍl Srei'yr (Lord Raze): Level 52 Sith Sorcerer