Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Game suddenly running slowly, and laggy.

STAR WARS: The Old Republic > English > Customer Service
Game suddenly running slowly, and laggy.

Volgarr's Avatar


Volgarr
03.05.2013 , 08:19 PM | #11
So yea, still incredibly slow and I've also tried everything with updating my computer and software.

Sucks seeing as I purchased a 30 dollar game card and the problems started happening a few days after I activated it.

nattodaisuki's Avatar


nattodaisuki
03.05.2013 , 09:48 PM | #12
Lol, not this argument again

It's YOUR computer(s)

YES, ALL of YOU who agrees with the Op

Then why do I have Zero problems. Zero Lag, Zero performance degradation, Zero CTD's ???

I must be special

Edit: Owenbrooks will be here shortly. Let's hear what he has to say
My slightly over-spec Rig, built specifically for Swtor: Core i7 3820 OC'ed @4.6GHz / MSI X79A-GD65 Mobo / Corsair Vengeance DDR3-1866MHz 8GB x8 / Four 120GB 6Gb/s SSD in RAID0 / nVidia GTX Titan / Enermax Platimax 1200 watt PSU / 3 Acer HN274Hbmiiid 3D Compatible 27inch monitors. CPU and the GTX Titan are custom water-cooled.

Volgarr's Avatar


Volgarr
03.10.2013 , 10:25 PM | #13
Not my computer, already checked everything. If it was, then why was the game running so smoothly before the patch?

Waiting for what he has to say...

spectreclees's Avatar


spectreclees
03.10.2013 , 10:38 PM | #14
I've noticed lag with changing companions and buying stuff. It's rather annoying. FPS is choppy once in a while but eh. I've seen worse.