Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

OK Bioware, what's with the lag and crashes??

STAR WARS: The Old Republic > English > Customer Service
OK Bioware, what's with the lag and crashes??
First BioWare Post First BioWare Post

Klarick's Avatar


Klarick
03.02.2013 , 04:37 PM | #1281
Quote: Originally Posted by jarjarloves View Post
show me one single article saying they had 545,000 subs at the end of 2012
Ok Jar Jar, I have asked you to pleazse stay on topic in THIS thread. This thread is NOT about the number of subs in SWTOR. There is another thread in the General forums that is disscussing this very issue. Please go there where we can continue the discussion in the appropriate thread. This thread is about those of us that are having issues with server instability.

I have asked you as respectfully as I know how to please respect those of us that are having the crashing and lag-spike issue. Please quit derailing this issue that is so important to so many of us.

I have reported you for attempting to derail this thread for trying over and over again to instigate a flame-war. I will never stoop to your level and I once again ask that you take the issue of subs to the appropriate General Forum thread.

Thank you for your understanding my friend. I wish you well,
Klarick
Klarick -- Healing PUGS since 16 March 1999

tbonemc's Avatar


tbonemc
03.02.2013 , 04:56 PM | #1282
It will be 3 weeks since ive played the game because of the new patches. I have had it. I have done what everyone has instructed me to do to fix the game and nothing worked. I think im just going to cancel my subscription because im not going to pay for a game i cant even play.

Count_Midnite's Avatar


Count_Midnite
03.02.2013 , 05:02 PM | #1283
Please, Please, PLEASE, Bioware, I want to play the game that I enjoyed 2 weeks ago.
Enough with the lag, I never had problems with Lag in 1.0, 1.1, 1.2, 1.3, 1.4, 1.5, or 1.6.
Ever since Gree Event ended I have been getting it so bad. Please fix it!

It sucks how I can't play a game I legitimately enjoy. Cheers. Please look after your subs!

Klarick's Avatar


Klarick
03.02.2013 , 05:02 PM | #1284
Quote: Originally Posted by tbonemc View Post
It will be 3 weeks since ive played the game because of the new patches. I have had it. I have done what everyone has instructed me to do to fix the game and nothing worked. I think im just going to cancel my subscription because im not going to pay for a game i cant even play.
Sad to see another joining the legion of those that have already left. How many people have to leave before something is fixed?

I hope you dont leave, but I do understand the frustration as I feel it as well. I'm just hoping that BW will start caring about the issues that affect so many of us.

I do wish you well and hope you find an MMO a little more stable than SWTOR. Good Luck my friend.
Klarick -- Healing PUGS since 16 March 1999

Faolitarn's Avatar


Faolitarn
03.02.2013 , 06:00 PM | #1285
I also agree. 2 weeks ago the game was running perfectly on my comp and now from time to time suddenly i experience EXTREME lags (which kills me quite often). it is pissing me off. i was paying for this game for quite a long time, but now i am wondering is it even worth any money with such issues?

Witnezz's Avatar


Witnezz
03.02.2013 , 06:08 PM | #1286
As a paying customer I think I have the right to say this is UN-****** acceptable!

PS: Fountain in Lions Arch looks great, and no CTD's or disconnects ... just saying.
--== 1020 ==--
--= 367 =--
--=111111=--

Stoicraven's Avatar


Stoicraven
03.02.2013 , 06:21 PM | #1287
all i get is crashing after the launcher login. Running a repair yet again to see if it fixes anything and since i know there is nothing wrong.........

brutall's Avatar


brutall
03.02.2013 , 06:22 PM | #1288
game crashing randomly
server tomb of freedom nad

jarjarloves's Avatar


jarjarloves
03.02.2013 , 06:39 PM | #1289
Quote: Originally Posted by Klarick View Post
Ok Jar Jar, I have asked you to pleazse stay on topic in THIS thread. This thread is NOT about the number of subs in SWTOR. There is another thread in the General forums that is disscussing this very issue. Please go there where we can continue the discussion in the appropriate thread. This thread is about those of us that are having issues with server instability.

I have asked you as respectfully as I know how to please respect those of us that are having the crashing and lag-spike issue. Please quit derailing this issue that is so important to so many of us.

I have reported you for attempting to derail this thread for trying over and over again to instigate a flame-war. I will never stoop to your level and I once again ask that you take the issue of subs to the appropriate General Forum thread.

Thank you for your understanding my friend. I wish you well,
Klarick
it is on topic since you brought it up. You are the one IN THIS THREAD who said 1.5 million have been lost. I just asked for clearification since there is no such news story saying so.

Also please explain how

1. Hundreds of thousands of people using the same internet as you logiing into the same server as you BUT HAVE DIFFERENT Hardware and software on their computer are not having a single problem. So logic dictates that it would be something on YOUR COMPUTER. Am i wrong?

IwantArancor's Avatar


IwantArancor
03.02.2013 , 06:41 PM | #1290
I keep having the same problem started like 30mins ago ill crash to Pick a server screen then ill quit out load back up and load into the game within 30 seconds i crash back to server screen ive done this 5 times now what the heck?