Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Unable to active Character- Bugged or poor workflow?

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
Unable to active Character- Bugged or poor workflow?

FatherMischief's Avatar

02.24.2013 , 02:00 PM | #1
Yesterday my wife logged back onto SWTOR after a long break. She is now F2P for the time being. She played all day yesterday without issue.

Today she logged on and deleted 2 characters from one server, then returned to the Shadowlands server. To her surprise she had to activate her toons. She clicked the activation button and nothing. All she received is the spinning waiting animation. After a bit of time we forced the game to close and tried again. After 6 tries I fired this off.

As I am doing this, my wife informs me that she:
  • Log into server.
  • Activate toon.
  • Wait one minute.
  • Close SW by way of Task Manager.
  • Launch SW.
  • Pick the next toon and repeat the process.

I am also informed that if you change servers all the active toons become inactive. I can understand this, however it would be nice if she was warned as such before having to do the crash your game over and over and over just to play a game.

I don't mean to be a bit judgmental, but who is your business analyst and why is he still employed? The work flow for this is horrific and it creates a terrible customer experience. Yes I understand you want them to become subscribers, but that does not release you from the responsibility of providing a quality product.

WaldoA's Avatar

02.24.2013 , 02:11 PM | #2
I think I had this problem when I first came back to SWTOR after f2p. Straight off the bat I had subscription so I didn't need to worry about what characters I activated, though.. when I clicked activate it would load for a second like you said then seem to do nothing, but after pressing activate maybe 2-3 times I believe it then worked. That being said, I believe I've seen people saying they've done the same and it has then used up a couple active characters slot but only one character activated. Take my poorly worded response and do with it as you will :P