Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

lagging in WZ till booted then stuck on load screen

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
lagging in WZ till booted then stuck on load screen
First BioWare Post First BioWare Post

Purge's Avatar

02.08.2013 , 08:57 PM | #1
Says it all. I cant finish a wz all day. Keeps lagging me out then in stuck on the load screen. Found nada about it. anyone else? Any fix?

Beruthien's Avatar

02.08.2013 , 09:12 PM | #2 This is the last staff post in this thread.  
Greetings Purge,

The first thing I would recommend would be to run the repair function on the launcher, to rule out any issues with the client files. To run the repair, please log in on the launcher, select the cog shape icon and then the repair function.

Also please make sure that you have added firewall and antivirus exceptions for SWTOR.exe and Launcher.exe and that the required ports have been opened on your router.

I would also recommend doing a Clean Boot to check if the issue still occurs then.

Please don't hesitate to come back to us if you have any further questions.

Thank you!
Beruthien| BioWare Customer Service Forum Support

Purge's Avatar

02.08.2013 , 10:20 PM | #3
Welp, tried everything you said. played a game after every "fix." Nothing changed. same problem....

OwenBrooks's Avatar

02.08.2013 , 10:26 PM | #4
The stuck on loading screen is a recent bug afflicting a number of people after the recent patch.

However this is only seen normally when a disconnect occurs, so need to try and work out why you are getting disconnected even just sitting in your ship. long idle disconnect ? or a connectivity issue ?
Hope this gives you more pointers to find an answer.

Purge's Avatar

02.08.2013 , 10:35 PM | #5
Yeah, its happening when i disconnect. But only in WZ's and in every single WZ. Yet to be able to finish one today. And all i do pretty much is pvp.

Anywho, thanks for your help. Ill keep trying

UPDATE: Tried updating drivers and rebooting internet network. Still happening every wz. Out of ideas....