Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Graphics Issues

Lord_Zapakna's Avatar


Lord_Zapakna
01.20.2013 , 09:14 AM | #1
I'm curious if anybody else is having this problem. I am running an Asus G73jh gaming laptop. It has been running SWTOR just fine for the past 4 months or so, but recently (mainly after the update/patch.) my Graphics card has been having issues with the game. I know it is only SWTOR because none of my other games (i.e. StarCraft 2, Sins of a Solar Empire, Minecraft, or Forsaken World) are having graphical issues. I have updated the graphics card driver in case it was that, but the problems persist. Another thing to note, it ONLY happens with i play my Sith Assassin, i can play my Sentinel all day and it won't bug out at all.

The game is freezing, I'm having artifacts and sometimes the game just doesn't display correctly. Below are the hardware/software specs for my laptop. Please tell me what i can do to fix this.

Intel® Core™ i7 Processor 620M/820QM/720QM : 2.66 GHz - 1.6 GHz, with Turbo Boost up to 3.33/3.06/2.8 GHz;
Genuine Windows® 7 Home Premium
Mobile Intel® HM55 Express Chipset
DDR3 1066/1333 MHz up to 8GB (Intel® i7-720QM / i7-820QM platform)
17.3" Full HD (1920x1080)/HD+ (1600x900) Color-Shine (Glare-type)
ATI Mobility™ Radeon® HD 5870, 1G GDDR5 VRAM
Dual SATA support up to 1TB (5400 rpm/ 7200 rpm)
DVD Super Multi
Integrated 802.11 b/g/n
I came, I saw, I bashed the hell out of it.

OwenBrooks's Avatar


OwenBrooks
01.20.2013 , 09:16 AM | #2
Have you run the repair option after login, lower left on launcher looks like a cog.

Lord_Zapakna's Avatar


Lord_Zapakna
01.21.2013 , 01:06 AM | #3
The weird thing is...now it works no prob. Played on my sith for more then 3hrs and had no issues. Idk what happened...but now no probs.
I came, I saw, I bashed the hell out of it.