Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Severe FPS drop...

Grendel_Prime's Avatar


Grendel_Prime
01.16.2013 , 05:16 AM | #1
Everything is fine, getting 50-70 fps and then as soon as combat starts, with even a single enemy, my fps drops to 5.6-7.0. Everything was fine up until last week.

AMD Phenom II 960T 6 core 3.0 Ghz
Sapphire 7750HD
4gb ram
Windows 7

Drivers are up to date

I know I could use more RAM but I get these rate drop even if I drop the graphics to medium or low.

Any suggestions?

Paokzu's Avatar


Paokzu
01.16.2013 , 05:21 AM | #2
I've noticed this also, it's not a terrible spike but it's definately enough to effect the gameplay. Since yesterday I've seen delays in the GCD and even abilities not recognizing that I clicked them. It's also taking me a lot longer to load the game and switch areas. Issues that weren't there before this most recent patch.
"You should never be in the company of anyone with whom you would not want to die."
http://www.cracked.com/blog/understa...ario-brothers/

Ighten's Avatar


Ighten
01.16.2013 , 07:14 AM | #3
Only thing I have noticed is a drop or odd hitch in alderaan and similar scapes.. It makes me think the trees have either been re optimized (more of them or diffferent LOD)..

TBF though its not significant enough to make that much difference and knocking the slider down a few notches seemed to solve it..

astrobearx's Avatar


astrobearx
01.16.2013 , 08:15 AM | #4
its not just you , i too also have been experiencing this and it is *********** irritating

i have to uninstall the game to see if it will fix this issue (im currently reisntalling)

this is *** man, i had no problem at all until the patch


a roll back is needed or something