Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Nvidia users try 304.79 Beta drivers

STAR WARS: The Old Republic > English > General Discussion
Nvidia users try 304.79 Beta drivers

OwenBrooks's Avatar


OwenBrooks
01.14.2013 , 02:42 AM | #11
Hi nosmos,

This has proven to help with stuttering

Quote: Originally Posted by Demetriscy

Fix #3: Note: This is the best fix which worked for me, it provided the most smoothest experience. If you have an nVidia GPU, go to "manage 3D settings" > "Program Settings" > "Add" (find the swtor.exe from the installed directory) > "Maximum pre-rendered frames = 1" > "Multi-display/mixed-GPU acceleration = Single display performance" > "Power management mode = Prefer maximum performance" > "Triple buffering = ON". The rest of the settings should be left as Default. Make sure you have max-prerendered frames on "1" and Triple buffering = ON as this is what I suspect is making the game run smooth.

MoobooMagoo's Avatar


MoobooMagoo
01.14.2013 , 03:55 AM | #12
This reminds me, I haven't updated my drivers in a while.
Explorer: 80% Achiever: 60% Killer: 47% Socializer: 13%

Daniel Erickson and the Amazing Technicolor Dream-Abs

ckoneful's Avatar


ckoneful
01.14.2013 , 05:24 AM | #13
Quote: Originally Posted by MoobooMagoo View Post
This reminds me, I haven't updated my drivers in a while.
If you aren't having issues you don't need to.

spectreclees's Avatar


spectreclees
01.14.2013 , 05:29 AM | #14
Quote: Originally Posted by AzraelCales View Post
Any suggestions for a GTX 460M laptop card?
If I remember correctly that's a 2 year old card. I usually like to upgrade in a 2-3 year time frame. Also, the fact it is on a laptop might not be helping. I hate to be the one to tell you so, but it's time to upgrade soon.

Divinus's Avatar


Divinus
01.14.2013 , 05:41 AM | #15
Running GTX 680 with 310.90 drivers, no issues over here.

Lionflash's Avatar


Lionflash
01.14.2013 , 06:36 AM | #16
Quote: Originally Posted by Onallion View Post
296.10

That is all.
I'm with you.

Been rockin' 296.10 for over a month. My computer auto-updates itself every 2 days and I have to roll-back to 296.10 every time because I lose 25-30 fps every time.

Rabelle's Avatar


Rabelle
01.14.2013 , 08:18 AM | #17
I also have a gtx 580 and what saddens me the most is that when SWTOR came out I had 85 fps on maximum setting and now, one year later, I struggle at 30 fps

Going to try the old drivers and hope it doesn't make a mess of other games.
Héx - Sorcerer The Red Eclipse

itsmymillertime's Avatar


itsmymillertime
01.14.2013 , 08:28 AM | #18
Bioware stated a while back to disable ambient occulation because there were known issues with the new ways shadows were being rendered. So this only fixes what Bioware told you to do in the first place.

Toweleeeie's Avatar


Toweleeeie
01.14.2013 , 12:08 PM | #19
Quote: Originally Posted by itsmymillertime View Post
Bioware stated a while back to disable ambient occulation because there were known issues with the new ways shadows were being rendered. So this only fixes what Bioware told you to do in the first place.
Wait... What? The driver uses AO. All drivers before 304.79 do not support it. I use it just fine.
Combine Force Melt and Cauterize. Combine Defencive Forums and Defencive Roll. Call it a day.