Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Long load times and bad FPS

STAR WARS: The Old Republic > English > Customer Service
Long load times and bad FPS

Dragovade's Avatar


Dragovade
12.28.2012 , 08:06 PM | #1
Hey, wondering if anyone can help with a problem i have been having with my game,

System Specs:
AMD FX 6 core @ 3.30 Ghz
8GB of ram
Radeon HD 7750 with 1 gb of ram.
Windows 7 64 bit
12.10 amd drivers

I got black ops2 for Christmas and couldn't play it after finding out the problem was a BIOS that needed an update now i can play black ops perfectly at high settings, now i cant play SW at all, the game takes 4 mins or more to load and 4 mins or so on each load screen when i get in game even with settings turned to the lowest i only get 30 FPS on my ship and 1-10 FPS in Ops, rendering the game virtually unplayable. i have take the computer apart and put it back tested all of the hardware (functioning properly) and rolled back drivers on the video card to 12.8 and up to 12.11 beta nothing works. even reformatted the hard drive and re installed windows. this whole time i am able to play black ops with out any load times and high settings. i tired almost all of the fixes i can find on the forums, checking to make sure the game is suing my processors, all of the video setting are where they are suppose to be.
before black ops and the BIOS update i could play star wars beautifully 30 sec or so load times and high settings no FPS lag what so ever, could do ops on high settings and not have a problem, I've exhausted all of my know how to fix the issue and it still exists, i don't think that it is a hardware problem (or i wouldn't be able to still play black ops 2) any help or suggestions would be useful.
i have also used the repairer to try and repair SW to no avail

Subnoiz's Avatar


Subnoiz
12.30.2012 , 03:57 PM | #2
Quote: Originally Posted by Dragovade View Post
Hey, wondering if anyone can help with a problem i have been having with my game,

System Specs:
AMD FX 6 core @ 3.30 Ghz
8GB of ram
Radeon HD 7750 with 1 gb of ram.
Windows 7 64 bit
12.10 amd drivers

I got black ops2 for Christmas and couldn't play it after finding out the problem was a BIOS that needed an update now i can play black ops perfectly at high settings, now i cant play SW at all, the game takes 4 mins or more to load and 4 mins or so on each load screen when i get in game even with settings turned to the lowest i only get 30 FPS on my ship and 1-10 FPS in Ops, rendering the game virtually unplayable. i have take the computer apart and put it back tested all of the hardware (functioning properly) and rolled back drivers on the video card to 12.8 and up to 12.11 beta nothing works. even reformatted the hard drive and re installed windows. this whole time i am able to play black ops with out any load times and high settings. i tired almost all of the fixes i can find on the forums, checking to make sure the game is suing my processors, all of the video setting are where they are suppose to be.
before black ops and the BIOS update i could play star wars beautifully 30 sec or so load times and high settings no FPS lag what so ever, could do ops on high settings and not have a problem, I've exhausted all of my know how to fix the issue and it still exists, i don't think that it is a hardware problem (or i wouldn't be able to still play black ops 2) any help or suggestions would be useful.
i have also used the repairer to try and repair SW to no avail
GREAT QUESTION! My specs are above the recommended settings as well, yet i have terrible load times and Horrible FPS. I have turned all the settings for the in-game graphics down, as well as run in compatibility mode. Still getting the same problem.

skomerko's Avatar


skomerko
12.30.2012 , 04:03 PM | #3
Had same problem. Set to Fullscreen (windowed) and Texture Quality to low. I noticed significant improvement in loading times and fps. Rest settings are maxed out. Befor that i had terrible disk lag.

Neosamuel's Avatar


Neosamuel
12.30.2012 , 04:34 PM | #4
I have had no problems with FPS, but I have had the game crash on me every once in a when I have more then one thing up at a time. I usualy play SWTOR in windowed mode that way I can switch what I am listening to in the background.

16GB Ram
Nvidia GTX 570 & GTX 470
All drivers up to date.
Sith Sorcerer
(((((((({=}[[ Now teach me how to make a Lightsaber Sig.