Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

the Mandalorian Killer

STAR WARS: The Old Republic > English > Classes
the Mandalorian Killer

Icerina's Avatar

11.10.2012 , 04:32 PM | #21
I just now completed this quest. The doors did lock on me , after respawning to the medical droid. I encountered the locked doors. BUT this is where it got interesting. After being frustrated, I accidently pressed the JETPACK mission item and it ported me THRU the locked doors and onto the ramp, thus killing the engineer and the 2 others.

Hope this helps someone.

SithLordDrew's Avatar

11.12.2012 , 03:53 PM | #22
I used the Ramjet and the Engineer didn't die. I then died by his two guards and released back to the medbay. I now have no way to get back up top to kill the Engineer. Is there a way to rebuild another ramjet? I would really like to continue this mission and finish the story.

-=Sith Lord Drew=- - Searchable holocron database of FlashPoints, Lore, and News centered on StarWars: The Old Republic Universe.

Swazzy's Avatar

01.16.2013 , 09:27 AM | #23
just had a problem with this quest as well, used the jet-pack ram but the dudes didn't die, and you only do 50 dmg to them each hit no matter what abilities you use, died and got put in the med and stuck. The only way out is to fleet pass back and reset the mission and do it again. on the second play through though you don't need the 75kills and this time the jet-pack worked cept i die upon using it but so did the 3 blokes on the perch. VERY dodgy mission, needs fixing otherwise you have to log out and wait 20hrs for a fleet-pass if you used it prior to getting there.
SupaFlea Swayzer - 39 - Gunslinger - Scav/Inv/ArmsTech

Gamble Swayzer - 34 - Mercenary - Slcr/UTrade/ArmrTech

Akiviri's Avatar

01.20.2013 , 07:03 AM | #24
I just don't understand how people are screwing this up. Does no one READ anymore? I had 0 problems with this. *HINT* the jetpack button is next to your quest....
Come to the dark Side ... we have cookies and Shock Collars

Gankstah's Avatar

01.20.2013 , 10:49 AM | #25
So, first time through playing a BH. Got to this point, it took me a moment to figure out what to do but it was pretty obvious. The BUG I encountered however was as soon as I clicked the ramjet item I was teleported up to the Engineer and his two bots and they instantly died but not before bombarding me with an array of god like damage.

I truly believe if I hadn't been 2 levels above the recommended level I would have been instagibbed.

Akiviri's Avatar

01.21.2013 , 05:01 AM | #26
Quote: Originally Posted by Gankstah View Post
I truly believe if I hadn't been 2 levels above the recommended level I would have been instagibbed.
Odd, as I was two levels under and survived just fine. Rocketed up, bad guys died, took about 25% health damage - done.
Come to the dark Side ... we have cookies and Shock Collars

Sieylianna's Avatar

08.11.2013 , 09:32 PM | #27
I have issues with this until I looked at the posts here. I tried climbing on the boxes and activating it in that general area, but it didn't work. It activated the first time I tried in the circle which is further back that where I was before and killed the chief engineer and his men. I barely survived because I hadn't expected to work and didn't use the shield.