Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Game crashes 1 second after hitting 'Play' in the launcher

STAR WARS: The Old Republic > English > Customer Service
Game crashes 1 second after hitting 'Play' in the launcher
First BioWare Post First BioWare Post

Arcanqt's Avatar


Arcanqt
04.30.2012 , 07:58 AM | #1
Hey, I'm having problems with getting the game to launch. Upon hitting the 'Play' button in the launcher, the screen will flicker black for a second (as if the game is starting), and then exit to desktop. This has been happening 100% of the time since I got my new computer (about 2 weeks ago). I have tried running FixLauncher and the Repair tool within the launcher, but to no avail. I have also made sure every driver, as well as DirectX are up to date, and all Windows Updates have been installed.
I'm currently running Windows 7 64-bit, my Graphics Card is an ATI Radeon HD 5700. I'm no computer wizard, but I'll try to answer any additional questions of course
In addition to making sure my drivers are up to date, I've taken the following steps to attempt to fix the problem:
-Set sleep and screensaver settings to Never.
-Ran the launcher and game as administrator.
-Ran the launcher with firewall and anti-virus disabled.
-Reinstalling the game.
Here's my DxDiag report:
Spoiler


Here is one part of a Launcher log (though I don't think the issue occurs here):
Spoiler

Here is one of the client logs (they are all identical, excepting the time and following hexadecimal number):
Spoiler

Lastly, there are no crash logs in the folder.

Thank you for looking into my issue

Beesodd's Avatar


Beesodd
04.30.2012 , 08:07 AM | #2 Click here to go to the next staff post in this thread. Next  
Greetings Arcanqt,

As you've surmised, the issue does not appear to be with the launcher, this is indeed showing a successful launch.

Please try navigating to C:\Users\%username%\AppData\Local\SWTOR\swtor\sett ings and look for the client_settings file in there.

Then change it so "D3DFullScreen = true" becomes "D3DFullScreen = false"
and "FullScreen = true" becomes "FullScreen = false", if these are present.

There are some issues that some players have been experiencing when attempting to play in Fullscreen mode, and this toggles the game to windowed. Please let us know if this helps.

Beesodd | BioWare Customer Service - Forum Support| Find help for all EA Games at Answer HQ.

Arcanqt's Avatar


Arcanqt
04.30.2012 , 11:37 AM | #3
Thank you very much, changing the settings allowed me to start the game

Beesodd's Avatar


Beesodd
04.30.2012 , 12:19 PM | #4 Click here to go to the next staff post in this thread. Next  
Thanks for letting me know that you're back in. If you have any further problems in future, don't hesitate to contact us.

Beesodd | BioWare Customer Service - Forum Support| Find help for all EA Games at Answer HQ.

Roguestarsandy's Avatar


Roguestarsandy
04.07.2013 , 02:04 PM | #5
ive tried the whole fullscreen from true to false and it didn't work. ive updated all my drives. ive ran fix launcher. ive ran as administrator. when i got on the game last weekend it worked fine, but now i cant get into the game. plz help.

Darkmatt's Avatar


Darkmatt
04.07.2013 , 04:02 PM | #6
Didn't fix ****

djpullen's Avatar


djpullen
04.07.2013 , 04:12 PM | #7
Quote: Originally Posted by Beesodd View Post
Thanks for letting me know that you're back in. If you have any further problems in future, don't hesitate to contact us.
could you please help me, none of the "fix" methods posted anywhere have worked for me
All i want to do is play the game

Yaesive's Avatar


Yaesive
04.07.2013 , 04:18 PM | #8
Did not help me either... This is what message I get too...

Error Message Image
Yaesive | Jo'lin | Fojea
Jedi Sage | Jedi Guardian | Smuggler
Jedi Covenant - Outer-Rim Recon Battalion Formerly Canderous Ordo
"Do or Do Not. There is no Try" - Yoda

Deanstalker's Avatar


Deanstalker
04.07.2013 , 05:54 PM | #9
I had the same problem...
I just tried to change the compatibility from Windows 7 to XP, and removed the "run as administrator" option, and now it launches and runs fine.
Try that too, guys.

Yaesive's Avatar


Yaesive
04.07.2013 , 06:01 PM | #10
Quote: Originally Posted by Deanstalker View Post
I had the same problem...
I just tried to change the compatibility from Windows 7 to XP, and removed the "run as administrator" option, and now it launches and runs fine.
Try that too, guys.
Nope did not help me
Yaesive | Jo'lin | Fojea
Jedi Sage | Jedi Guardian | Smuggler
Jedi Covenant - Outer-Rim Recon Battalion Formerly Canderous Ordo
"Do or Do Not. There is no Try" - Yoda