Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

First time ever launching game crashed

STAR WARS: The Old Republic > English > Customer Service
First time ever launching game crashed
First BioWare Post First BioWare Post

JohnPaul's Avatar


JohnPaul
04.27.2012 , 05:21 AM | #1
Hi

Just bought the game and after every thing got installed tried launching for the first time, went as far as the first cinematic and after that crashed to desktop and that was that?? Tried to launch again but when it asked me to log in i did but then said i already was?? im not running the best or newest of pc`s but should def be up for the task of playing the game..think i might have to poke around with settings but really dont know much about computers!! Any and all help would be fantastic..Thanks

Beruthien's Avatar


Beruthien
04.27.2012 , 06:05 AM | #2 Click here to go to the next staff post in this thread. Next  
Greetings JohnPaul,

Could you please post your full DxDiag so we would be in a better position to assist you? (When posting the Dxdiag please paste it with in the [SPOILER][/SPOILER] tags.)

Thank you in advance!
Beruthien| BioWare Customer Service Forum Support