Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Companion lightsaber always on

STAR WARS: The Old Republic > English > Customer Service
Companion lightsaber always on

NikPer's Avatar


NikPer
04.27.2012 , 04:27 AM | #1
After the update all of my lightsaber using companions(on both my main and alt) are having their lightsabers always turned on. I try sending them on missions, equiping and re equiping lightsabers, logging in and out, but nothing helps... Any advice how to solve this problem?

ViridisDraco's Avatar


ViridisDraco
04.27.2012 , 04:30 AM | #2
Quote: Originally Posted by NikPer View Post
After the update all of my lightsaber using companions(on both my main and alt) are having their lightsabers always turned on. I try sending them on missions, equiping and re equiping lightsabers, logging in and out, but nothing helps... Any advice how to solve this problem?
it's a bug relative to their "stance", try to deactivate it
Tsarthai - Jedi Guardian - Officer of "Operation Edge"- The Progenitor
Quote: Originally Posted by Fornix View Post
Don't expect reason or logic to apply here, this is just one of the forms of SWTOR endgame:
- Flashpoints - Operations - Space - PvP - Forum ranting & trolling

NikPer's Avatar


NikPer
04.27.2012 , 04:36 AM | #3
Riskinig to sound like a complete noob but... What precisely should I deactivete and how?

Freor's Avatar


Freor
04.27.2012 , 04:40 AM | #4
Yep, 1.2 made it worse. Pre-patch, only one stance (the dot stance in my case) made the companion keep the blade active. Now it's bugged for both stances. Only way (as previous poster mentioned) is to not use any stance. Pretty annoying.

Seeing there's already a visual bug about companions going invisible with certain infected customizations on the "known issues" list, would be nice to get this one there too. All you have to do is check fleet to confirm the bug: can't miss the companions running around with blades on (or pointing with guns)

Bomyne's Avatar


Bomyne
04.27.2012 , 04:41 AM | #5
Quote: Originally Posted by NikPer View Post
Riskinig to sound like a complete noob but... What precisely should I deactivete and how?
Press ~ to call up the companion bar and click the ability that has a 'dot' under it. Then click it again to turn it back on.
"Sometimes, The obvious choice is the wrong choice."

TeilCron's Avatar


TeilCron
04.27.2012 , 05:07 AM | #6
LOL I already made a post about this http://www.swtor.com/community/showthread.php?t=431939, only 2 days as and as stated it's been around for a while now.
Sto'Vo'Kor DreddPool Raz'Taruran

NikPer's Avatar


NikPer
04.27.2012 , 05:30 AM | #7
Ok I'll try that. i had no idea "stances" even exist, i used the default setting for the companions and never changed it (never even give any manual command to the companions expect attack ). Thanks...