Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Oh no, Another Patch with Downtime!

STAR WARS: The Old Republic > English > Customer Service
Oh no, Another Patch with Downtime!

sankalp's Avatar


sankalp
04.27.2012 , 02:59 AM | #31
Quote: Originally Posted by apollor View Post
People its a patch get over it.

All you people ever do it ***** about this game I'm glad that Bioware is taking the time to fix problems so *********** what if they bring down the game for a few hours on a friday night or the weekend just be glad the problems are being fix.

you people have nothing else better do to than to complain about a brilliant game?
Yeh ill see what happens when you make plans with 8 other ppl and come back to find this crap all over the place. Once in a while I can understand, twice in 3 weeks is ****ed.

Garbin's Avatar


Garbin
04.27.2012 , 03:03 AM | #32
Stop moaning, servers are up.

DapperDab's Avatar


DapperDab
04.27.2012 , 04:16 AM | #33
Quote: Originally Posted by Garbin View Post
Stop moaning, servers are up.
No, I'm butthurt.

Rezac's Avatar


Rezac
04.27.2012 , 04:22 AM | #34
after patch 1.2, I had download issues and I spent my 8 hrs of playtime (yes I play alot) trying to fix downloading errors for 7 days. No, I didn't get any 30days free and the 3 days I should have gotten free... I didn't.

now another maintenance, another patch and another error. the servers all say light and that they're up but I'm back to the same old issue of trying to download an 11.63 gig english asset file that took me 7 days to download the last time because of a crazy error on their end.

Angry isn't the word now, I'm playing on MY time and fixing Their error. *rolls eyes*

DapperDab's Avatar


DapperDab
04.27.2012 , 04:29 AM | #35
Quote: Originally Posted by Rezac View Post
after patch 1.2, I had download issues and I spent my 8 hrs of playtime (yes I play alot) trying to fix downloading errors for 7 days. No, I didn't get any 30days free and the 3 days I should have gotten free... I didn't.

now another maintenance, another patch and another error. the servers all say light and that they're up but I'm back to the same old issue of trying to download an 11.63 gig english asset file that took me 7 days to download the last time because of a crazy error on their end.

Angry isn't the word now, I'm playing on MY time and fixing Their error. *rolls eyes*
Not sure if it will help but I had to have my roommate turn his account control off for the game to patch to let him play. He kept getting some error if he ran it as a regular user so try adjusting that.

I have it completely disabled because it's mostly just a crutch for window users to think they're safe. Do some research and you'll see microsoft say the same.