Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Really bad lag issues HELP

JordyBoy's Avatar


JordyBoy
12.14.2011 , 03:50 PM | #1
Anyone else expriencing this my game play was fine in beta and now it sucks in early launch cant even play properly, my game play is ruined

JordyBoy's Avatar


JordyBoy
12.14.2011 , 03:51 PM | #2
anyone give me any tips on how to improve this?

Ravoss's Avatar


Ravoss
12.14.2011 , 03:51 PM | #3
Stop the ****.
Co-GM of The Argent Legion
Sith Armies - Central Time

JordyBoy's Avatar


JordyBoy
12.14.2011 , 03:52 PM | #4
and what does that mean?

Gomuningen's Avatar


Gomuningen
12.14.2011 , 03:54 PM | #5
Quote: Originally Posted by JordyBoy View Post
Anyone else expriencing this my game play was fine in beta and now it sucks in early launch cant even play properly, my game play is ruined
You will need to be more specific about your problems. Also your computer specs would help as well.

amdhalo's Avatar


amdhalo
12.14.2011 , 03:56 PM | #6
o my god my g8mplay is ruined!!1
Get over it, you have 6 more days to play on early access and then as long as you like after the 20th. The lag is likely due to the thousands of people simultaneously logging in. Give it a day or two and if it persists, roll on a different server, or even a newly created server. I'm pretty sure the player cap on each server is being increased every day anyways.

Yuh.

datopgamer's Avatar


datopgamer
12.14.2011 , 03:57 PM | #7
To be more helpful we would need your computer specs. Mainly the cpu, memory and graphics card. Without those it'll be hard to determine what the problem could be.