Thread: Running SWTOR
View Single Post

OwenBrooks's Avatar


OwenBrooks
03.06.2013 , 01:25 AM | #7
Laptop coolers do exist for a reason, saves burning our laps

Make sure power option is set to high performance and not balanced, this can restrict the CPU. (will make more heat though most likely)

Give Fullscreen Window a try if you run in fullscreen to see if it helps

In the Nvidia Control panel try these settings they may help

go to "manage 3D settings" > "Program Settings" > "Add" (find the swtor.exe from the installed directory) > "Maximum pre-rendered frames = 1" give 2 a try as well for comparison.
> "Multi-display/mixed-GPU acceleration = Single display performance"
> "Power management mode = Prefer maximum performance"
> "Triple buffering = ON". Turn to OFF if you do not use Vsynch

Can you try the following settings and see if it also makes a difference, have a play to see what helps
Maximum Character Distance = Low
Draw Distance (FarClipScale) all the way to <0.70

See how that goes first up