Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

[Normal] The Foundry bugged after killing boss

STAR WARS: The Old Republic > English > Flashpoints, Operations, and Heroic Missions
[Normal] The Foundry bugged after killing boss

Korous's Avatar

12.28.2011 , 07:55 PM | #1
After killing Revan the Flashpoint quest vanished from my questlog. I was unable to turn in the quest at Moff Phennir and I can't get the quest again from Sergeant Lodani.

I tried to get the prereq Flashpoint (Boarding Party) from Sergeant Tebar but he has no quest symbol above his head either.

Im locked out from both Flashpoints now. My buddy who did "The Foundry" with me didn't have this problem...

Anybody encountered this bug and have any suggestions?

Ticket is open but Im not holding my breath...

Korous's Avatar

12.29.2011 , 08:19 AM | #2
As it turns out my whole progress for "Boarding Party" and "The Foundry" was reset after killing Revan. I have to start at "Call To Arms" again.

Well, this sucks...

Nessirin's Avatar

12.29.2011 , 08:23 AM | #3
At least you got to kill him... For us, he just bubbled himself into perma-immunity.

thatjoshdude's Avatar

12.29.2011 , 10:58 AM | #4
Yea permantent immunity bug so lame

upandb's Avatar

12.29.2011 , 03:22 PM | #5
What you have to do is make sure he isn't using Force Storm when he gets to 5% health. The fight stops at 5%, but if he's taking damage at 5% while channelling force storm, it won't work. We all just died, then on the second time it worked. Don't reset the instance and don't reset the quest, just kill yourselves and make sure you be careful under 10% health.
[SWG] Prit Kolem, Master Commando, Lowca Server
[SWTOR] Scarlett: Juggernaut, CEO of Veridian Dynamics on Davik's Estate