Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Security Questions STILL not working

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
Security Questions STILL not working
 
First BioWare Post First BioWare Post

Exarr's Avatar


Exarr
12.13.2011 , 06:11 PM | #21
To all the people saying they are on hold atm: I hate you :P (jk)
No seriously I can't get through at all. Not even to wait on hold. Ok I know these things can get crazy on day 1 or, day -7 in this case... But like, I worked at call centers before. I know how backlogged it can get, I really do. But I've NEVER had an experiece where the automated system hangs up on you, instead of letting you wait in queue... Arrgg.. Well, atleast I have other things to do in life >.>

Devlin_trigger's Avatar


Devlin_trigger
12.13.2011 , 06:11 PM | #22
my other account is having the same issue... it has the same details as this account for the security questions and worked fine this morning... upto 1hour 15 minutes on hold at the moment...

obi-juan's Avatar


obi-juan
12.13.2011 , 06:11 PM | #23
Friend just sent this e-mail to SWTOR support:

Quote:
I have been trying to call and e-mail you all day, you've done nothing but send me automatic e-mail replies that have not been helpful. I have reset my password as you instructed and nothing has changed. There is a forum thread that lists my problem in detail. Your phone line is not picking up, stop telling me to call... I can't... you don't have the capacity to handle this problem via phone. All I want are my questions reset so I can login. You are ruining something I have been so excited about (and a lot of others are in the same boat). I hope you actually READ this e-mail and RESPOND not as a "protocol droid" but an actual customer service representative that can help.

Here's the thread I mentioned: http://www.swtor.com/community/showthread.php?t=9706
Wonder if that'll get a response.

Devlin_trigger's Avatar


Devlin_trigger
12.13.2011 , 06:15 PM | #24
for those who are feeling left out...

*Music*

"Your call is important to us and your call will be answered as soon as an agent becomes available"

*Music*

Archangel's Avatar


Archangel
12.13.2011 , 06:16 PM | #25
Somehow I finally got through and I'm in the queue, but obviously I've been already waiting for some time. Unfortunately I'm on my cell, so hopefully it doesn't disconnect.

I'll update the post with how long I actually waited until I spoke to a human.

But seriously, this whole security question crap is just bogus. If I reset my password, I should be able to change the security question. And if the Origin/SWTOR accounts are single sign-on, why isn't the security question accessible via the Origin account? Once I login, I should be able to alter it. Anyways, same things everyone else has said, so guess we just have to wait for a fix.
Through victory, my chains are broken.

Prevailer's Avatar


Prevailer
12.13.2011 , 06:16 PM | #26
I'm having the same problem. 32 minutes in queue calling them last night before I gave up. Sigh.

wesclark's Avatar


wesclark
12.13.2011 , 06:18 PM | #27
i've been in queue for 2 hours now. Anybody gotten through?

Devlin_trigger's Avatar


Devlin_trigger
12.13.2011 , 06:21 PM | #28
they have one person on CS... and they're having a break :P

obi-juan's Avatar


obi-juan
12.13.2011 , 06:21 PM | #29
I know they're busy, but aren't there forum devs who exist to read threads just like this one and respond to them?

mephistoqc's Avatar


mephistoqc
12.13.2011 , 06:27 PM | #30
Add me to the group of people who can log in but can't answer their security questions because it won't take the answer. I've given up trying to call CS at this point, maybe it'll be better in the morning.