Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Steam Overlay - Working on win7

STAR WARS: The Old Republic > English > General Discussion
Steam Overlay - Working on win7

Serpenttt's Avatar


Serpenttt
12.28.2011 , 06:47 AM | #11
Not working for me sadly, it launches the launcher like it should then closes down once you login.
Serpentine | 50 Sentinel | Lord Adraas

renegadelink's Avatar


renegadelink
12.28.2011 , 09:50 AM | #12
Quote: Originally Posted by Morberis View Post
Doesn`t work for me.

Does the title in steam require the quotation marks as well?
No, the quotes are not required, i will edit the main post. The icon and name are optional. It's the Target and StartIn fields that are required.

Superleggera's Avatar


Superleggera
12.28.2011 , 10:41 AM | #13
It runs the script, shows I'm in the game via steam. However it does not run the launcher. So now it says I'm playing the game but I'm not and I cannot get out of the game. I'm not sure how to close out of the script.

Zeeth's Avatar


Zeeth
12.28.2011 , 11:17 AM | #14
For those having issues, I would double check that all the paths are correct, check that C:/windows exists, check where your bioware install is located and change accordingly.


Non 64bit systems WILL have different paths. Honestly though valve or bioware should fix this. It worked fine in beta.
"Heretics crave the cleansing fire of absolution. They need not fear, for we shall deliver"

TWIN_SUNZ's Avatar


TWIN_SUNZ
12.28.2011 , 11:44 AM | #15
Launcher doesn't start for me, I get:
Code:
D:\Games\Star Wars-The Old Republic\steamswtor.vbs(13, 27) Microsoft VBScript 
compilation error: Syntax error

Loqe's Avatar


Loqe
12.28.2011 , 12:05 PM | #16
Thanks, worked like a charm on win7 x64!

Chromiie's Avatar


Chromiie
12.28.2011 , 12:06 PM | #17
I love you OP!
Quote: Originally Posted by DamionSchubert View Post
We don't have friendly fire in The Old Republic for a simple reason: a lot of players are, well... idiots. I don't mean you, of course, dear reader

Lonkley's Avatar


Lonkley
12.28.2011 , 12:58 PM | #18
Quote: Originally Posted by renegadelink View Post
This also runs the swtor client in non-admin mode which is a nice security perk.
But is it a good idea not to run as Admin (from Bioware's perspective, not reality). They probably do so because of careless coding issues. It might launch and play fine up until some weird things start to happen because of permission failures. Sort of a shotgun approach to making it work right.

LilPika's Avatar


LilPika
12.28.2011 , 01:16 PM | #19
Runs the script, launcher starts, I sign in and the game loads, but I can't access the overlay D:

So close!

Edit: Also no longer classed as being in game on Steam D:
Neutral Auction House, trainers and bank all on Nar Shaddaa, Lower Promenade. Start trading there already!

jinatreides's Avatar


jinatreides
12.28.2011 , 01:20 PM | #20
Thanks alot, works perfectly for me