Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Stealth Rez broken?


Threjyan's Avatar


Threjyan
07.10.2017 , 03:56 AM | #1
i posted in class forums but i thought about general forum, would get more visability and a possible reply from a dev.

http://www.swtor.com/community/showthread.php?t=926825

"when did they fixed and why did they do it?

its basicly impossible to stelth rez after 2 sec of casting it stops/breaks cast and we get into combat..kinda suxx tbh"
..The Path Of Excess Leads To The Tower Of Wisdom..

Nightblazer's Avatar


Nightblazer
07.10.2017 , 04:25 AM | #2
Probably best to post in the bug reports section of the forums
“PATIENCE YOU MUST HAVE my young padawan”

– Yoda

Get 7 days free game time plus several unlocks by clicking here

Chelz's Avatar


Chelz
07.10.2017 , 04:41 AM | #3
Stupid question maybe but did you have hot's out?

masterceil's Avatar


masterceil
07.10.2017 , 04:52 AM | #4
I'm starting to wonder if this is actualy an issue for some people... I stealth rez on my Ruffian on the regular, and while I don't play my Shadow very often, I have stealth rez'd with her since the last backend maintenance. There may be some weird situational bug or something... I haven't seen this happen myself, but this is like the fourth time in a week or so that I've seen this complaint on the forum.

The one time my stealth rez didn't work was due to raid-wide damage pulling me back into combat, but others swear that's not the case here...

Edit: Out of curiosity, for those that are having problems, is it happening every time? Or just often enough to be annoying? Is it only in Operations, or have you also tried it in FPs/Uprisings/World etc?
Appreciate the help/snark in the above post? Click here to help me out!
Celestial ArgonautsCelestial Dreadnauts
Star Forged from the Ebon Hawk cacd.enjin.com

Vercundus's Avatar


Vercundus
07.10.2017 , 04:58 AM | #5
It will be broken if you or a dead player are too close to the boss or adds, stand in the circles, have DoTs, HoTs or any other buff from other players...
Choices matter... I choose not to sub until conquest is fixed...

My referral link http://www.swtor.com/r/jRpChs

Torvai's Avatar


Torvai
07.10.2017 , 05:47 AM | #6
Quote: Originally Posted by Vercundus View Post
It will be broken if you or a dead player are too close to the boss or adds, stand in the circles, have DoTs, HoTs or any other buff from other players...
Proximity to a mob won't pull you into combat.
Attacking, getting attacked, healing others(which is why Roaming Mend puts you into combat) and an add spawning are the only things putting you back in combat.
And yes, lately nothing happens, nothing mentioned in the log and still you get put in combat.
To the one who asked: it's not every time as far as I can tell, but more often than not.

Rasinator's Avatar


Rasinator
07.10.2017 , 05:53 AM | #7
I been in every SM Op for daily group finder and Vet Mode EV, KP TFB all cannot stealth rez. Lots of complaints on this in fleet chat. Currently on "TEH" server. No hots, buffs, aoe damage away from others including boss. Feature broke just like group finder. Bioware fix your game. This is insane and makes it hard to keep playing.
Trent
Dragonstone Legacy (Star Forge)
Enter my link in browser. You get rewarded as well as I even as a sub player.
http://www.swtor.com/r/nxRKyW

Threjyan's Avatar


Threjyan
07.10.2017 , 10:04 AM | #8
Quote: Originally Posted by Chelz View Post
Stupid question maybe but did you have hot's out?
its not a stupid question, its a very valid question, but yes, i had all hots/dots out, and for example if i try to stelth rez on cora hm, before ruggar, where there is absolutly nothing happening, it brakes the cast exactly at 2 seconds putting me in combat. but thats not the only situation, on brontes on finger phase, when i have time after the last add is dead, it also breaks at 2 seconds cast (could be some aoe dmg, but it still broke at 2 seconds cast)

the thing is, if it was a bad rez ok i can live with that, my inability, lack of skill, now if they changed intentionally, and didnt mention it it kinda suxx, we loose a huge skill, that obviously nneds some coordination to do, but even so, its an awesome raid utility.
..The Path Of Excess Leads To The Tower Of Wisdom..

scardera's Avatar


scardera
07.10.2017 , 10:16 AM | #9
yeah a lot of stealther in my guild complain about this probably just another way for bioware to slow progression for there game with no ops contends

dscount's Avatar


dscount
07.10.2017 , 10:19 AM | #10
I saw the same thing this weekend trying to Stealth Rez multiple times. Failed no matter what I tried.

HOTS gone, between AOE from boss, No Guard, Popped Evasion, etc. (Operative and Scoundrel both had issue)

Seemed like it was broken.
Reference Link: Why not? http://www.swtor.com/r/FDltnT
WTB Legacy Bound Ear, Implants, Relics