Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Game crash at launch

geofraynils's Avatar


geofraynils
05.03.2017 , 12:02 PM | #1
Hi, swtor crash at launch after clicking on "play" button on laucher, each time there is an action done during loading. It's realy annoying to wait full loading time or relauch game each time i forget it and press alt+tab or any other combination as recording....
I'm on W10 creator update with graphics drivers updated on their last published update. Hope you will find any solution.
Serveur : Mantle of the Force - Guilde : ePic'Fail - PVE HL/PVP. - Rédacteur pour le site communautaire game-guide.fr

brunobragajc's Avatar


brunobragajc
05.03.2017 , 06:24 PM | #2
Worked here:

go to: C:\Users\[username]\AppData\Local\SWTOR\swtor\settings

and delete the "PlayerGUIState" file (like characternameGUIState) of your characters and see if you can then log in with that character. (this is your quickbars and those things...)

Kuniyosh's Avatar


Kuniyosh
05.04.2017 , 11:06 AM | #3
This didnt work. I have the same problem. If you click anywhere, left or right mouse button or another window on extended display the game WILL crash on character selection. EVERY. SINGLE. TIME.
"I have studied you, and found nothing but weakness."

dr_mike's Avatar


dr_mike
05.04.2017 , 11:33 AM | #4
Try forcing a repair and see if that helps: http://www.swtor.com/community/showthread.php?t=729911

May also want to look in the /logs directory under where you have the game installed to see if any errors got dropped in there.
Who knows what lurks in the minds of those crazy Sith....
1% gets donated to unemployed Jawas living on Hoth

geofraynils's Avatar


geofraynils
05.04.2017 , 01:14 PM | #5
repair didn't changed anything.
Serveur : Mantle of the Force - Guilde : ePic'Fail - PVE HL/PVP. - Rédacteur pour le site communautaire game-guide.fr

sakica's Avatar


sakica
05.04.2017 , 01:20 PM | #6
Same here, played today and now in evening on character screen game just crash. SWTOR stopped working.

It seem that repair fixed issue for me.

brunobragajc's Avatar


brunobragajc
05.07.2017 , 02:51 PM | #7
Guys, I solved the problem here...
It was my Gforce graphic drive... I uninstaled using a DDU software and re-instaled it in a clean way...search on youtube how to do it... now it's working, no more crashes!
I did not installed Gforce Experience, Shield and other stuff.. do the clean way and everything is going to be okay....

sakica's Avatar


sakica
05.08.2017 , 06:40 AM | #8
Well for me game started crashing again after two days without problem. Now I delete GUIprofiles folder and it starts normal but it will probably crashing again in few days. I think that is something with game itself.